JKOwners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,021 Posts
Discussion Starter #1
I few weeks ago i noticed that when i tried to use the momentary (3 blinks) right signal, sometimes it wouldn't work the first time.

Well, a few days ago i tried to use the signal and...the wipers wiped once! After checking that my hands weren't near the wiper switch and that my sanity was in check, i realized trouble was brewing.

Now the right signal only works if applied all the way on, if not all dash lights flash!

Anyone else ever experience similar shorts? Just asking before my trip to the dealership.

TIA
 

·
Registered
Joined
·
803 Posts
Might not be a short, all kind of weird things happening if the battery is on it's way out so get the battery tested.
Also sometimes a computer reset resolves such issues (disconnect battery for 10 - 30 Minutes)
 

·
Registered
Joined
·
525 Posts
It could be the multifunction control switch that is in the steering wheel, it controls your wipers, lights etc.
Mine went bad in my 08 and the dealer chased after it for 7 weeks before they finally narrowed it down to the switch.
My symptoms were different than yours though. It kept waking up the guage cluster and draining the battery. While chasing the issue, they replaced the TIPM twice, guage cluster and several other items.
Good luck.
 

·
Registered
Joined
·
1,021 Posts
Discussion Starter #4 (Edited)
Thanks fellas.
My battery is about a year old.
It acts like a short because if i hold the stalk for a while without pushing it past the detent, after doing nothing for a few moments, all dash lights flash once then the turn signal goes on. If I initially push the stalk right past the detent, it will activate the turn signal, albeit after a slight hesitation. Seems pretty consistent now. Guess that switch is bad.

Funny thing is, I don't even use the turn signal as much add i should! Lol

ok, in it goes! :-(


EDIT: if I hold the switch in momentary position, it turns on the windshield wipers and the parking lights and stays that way until I do something else. in other words the parking lights are not flashing like a loose wire or short, the switch is going haywire. Hopefully this is a simple swap.

AdamIsAdam
 

·
Registered
Joined
·
1,021 Posts
Discussion Starter #5
It could be the multifunction control switch that is in the steering wheel, it controls your wipers, lights etc.
Mine went bad in my 08 and the dealer chased after it for 7 weeks before they finally narrowed it down to the switch.
My symptoms were different than yours though. It kept waking up the guage cluster and draining the battery. While chasing the issue, they replaced the TIPM twice, guage cluster and several other items.
Good luck.
winner! Multifunction switch was the culprit. Fixed under extended warranty :)

AdamIsAdam
 
1 - 5 of 5 Posts
Top