JKOwners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
789 Posts
Discussion Starter #1
The far left knob (that lets you adjust which vents are being used - Dash only, Dash/Floor, Defrost, etc.) doesn't seem to have any effect, no matter what I select it always blows dash and floor. The switch doesn't feel loose or anything weird.

Any ideas before I take it to the dealer? (It's under warranty)
 

·
Administrator
Joined
·
8,731 Posts
The far left knob (that lets you adjust which vents are being used - Dash only, Dash/Floor, Defrost, etc.) doesn't seem to have any effect, no matter what I select it always blows dash and floor. The switch doesn't feel loose or anything weird.

Any ideas before I take it to the dealer? (It's under warranty)
Mine is doing that too ever since I had to have the dash replaced after getting my radio thieved.

Mine is stuck on mix of floor and vent.

I would bring it back to Moose to get it fixed properly but that f00ker up and moved to AZ!! :thefinger:
 

·
Registered
Joined
·
2,770 Posts
I can't put mine on defrost it's getting stuck and won't move. I don't have any ideas but if you take it to the dealer can you let us know what they do?
 

·
Registered
Joined
·
789 Posts
Discussion Starter #4
Interesting, come to think of it I did loosen my dash some time ago because I tapped into one of the 12 volt plugs to power my CB. I wonder if that's when it stopped working and I just never tried to change it until recently. There has to be something that wasn't lined up when I put it back together.
 

·
Registered
Joined
·
854 Posts
Mines messed up to, was hoping for some wisdom to fix it.
 

·
Registered
Joined
·
1,886 Posts
Sounds like the cable has become disconnected from the knob, or from the mode wheel.

Remove the glove box. Look in toward the center. The white plastic wheel is the mode control.
See if the cable is connected.
If it is, turn the mode control knob. If the white plastic wheel does not rotate, the cable has disconnected from the control knob.

Another possibility is the cable casing anchor has broken, making it so the casing moves back and forth, instead of the cable.
There is a cable casing anchor on the end by the control knob, too.

 

·
Registered
Joined
·
854 Posts
All of that looks good to me haven't tried to turn it on and test after cleaning out three years of dirt and missing things I found in there.
 

·
Registered
Joined
·
185 Posts
I can't put mine on defrost it's getting stuck and won't move. I don't have any ideas but if you take it to the dealer can you let us know what they do?

I fought my dealer on this for a few months while mine was still in warranty. They wanted to charge me $900+ for the dash removal and reinstall once they got to the heater shutter box. They took me into the shop and showed me that dirt daubers(flying insect) had build a nest on th shutter lever. Well after I politely told them to "pound sand!" at that price we settled on a fair price ($200) and I picked the Jeep up the very next day. I picked it up in the afternoon only to notice that it still wouldn't go into defrost, so back into the dealer it went.

Without getting into all the gritty details; it took replacing the entire heater box(not just removing a dirt dauber's nest) and shutter assembly to fix that problem in my 2007. I never got my $200 back for the "dirt dauber" incident, but at least I have th problem fixed now. It really left me dumbfounded that the tech working on the Jeep never checked the operation of the knob after going through all that work on the first repair of removing the dash. Hope my experience sheds some light on your troubles. :beer:
 

·
Registered
Joined
·
1 Posts
Great suggestion. Installed stereo a couple months ago, and pulling out the center console resulted in separating the mode control wheel from the cable mechanism. Remember to reseat at full left or right to maintain the proper range from foot to defrost.
 
1 - 9 of 9 Posts
Top