JKOwners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have my 2012 Jeep Wrangler 4 years. I noticed that when it sits 3 days or more, it starts up with a lifter rattle. At 36000 miles I changed the oil myself and added an additive to keep the engine parts coated. I used Duralube. Rislone is another product I used on vehicles with lifter noise. The engine already has an extended warranty on a lifter or two. I don't believe the oiling system is adequate. They probably require synthetics.
 

·
Registered
Joined
·
420 Posts
Billy,

My wife's 2012 does the same thing. Sits a week and sound like a bucket of bolts for a few seconds. I think it is the lifters involving the VVT. My friends 2015 is quiet on startup. We haven't had the head issue and when running after the rattle it's dead quiet so I don't sweat the noise.
 

·
Registered
Joined
·
31 Posts
I too have a 2012 that does the same thing. From what I have read, this seems to be a fairly common thing with the pentastar engine.
 

·
Registered
Joined
·
356 Posts
Both our 2015 & 2016 JKs do this for a few seconds upon start-up.

We had a similar problem on my wife's '09 (3.8L) when she had it. I swapped the Mopar brand oil filter out for a Frame ToughGard and the problem went away. I later switched back to a Mopar filter and the problem came back. I think anti-drainback valves in the Mopar filters weren't so good.

I know a lot of forum people hate Frams, but I've never had a problem. I've always ran the ToughGards though.
 
1 - 4 of 4 Posts
Top