JKOwners Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
horn quit working/ ck 2 fuses looks ok.// also i have a problem w/right side front blinker park light. blinker will work but quits when i turn on park lights on. I read an earlier thread about multifunction switch in which might be the park light prob. //First post, hello to all
 

·
Registered
Joined
·
430 Posts
my horn went too last week, it works but is really muffled sounding, almost can't hear it when arming the door locks
 

·
Registered
Joined
·
27 Posts
Discussion Starter #6
cruise control works. no airbag light on. Blinker problem;from what I have determine I'm not getting a ground through park light socket but I'm getting power to it. i have cleaned ground for light on body. Dealer told me the ground goes through multifunction switch for light and HORN. I have ordered switch from advance auto [80$ dealer 130$} PS, the blinker works but quits when i turn on park light. Give update when multi-switch gets here in 2 days
 

·
Registered
Joined
·
27 Posts
Discussion Starter #8
Multifunction switch did not fix it. now the left park light out. horn out, front park and blinkers not working. only getting 3.5 volts to lights.
 

·
Registered
Joined
·
1,694 Posts
my horn went too last week, it works but is really muffled sounding, almost can't hear it when arming the door locks
You're problem is easy. Horn is filled with water/mud. Give it a week or two and it will return to it's normal strangulated goat sound.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #10
horn, front park lights and blinkers FIXED/// the problem was a ground wire from steering column to computer [timp] beside batterie under hood. dealer spent few hrs trying to fig out. Had hidden broken ground. dealer ran new separate ground instead spending too much time finding break in wire. Dealer said solder joints break in wires, causes probs. dealer also said if you have a lot of miles with no probs with computer, you won't have any later on. i got 100000+
 

·
Registered
Joined
·
430 Posts
You're problem is easy. Horn is filled with water/mud. Give it a week or two and it will return to it's normal strangulated goat sound.
well, true to your word, it did in fact fix itself, and yes still sounds like a strangled goat, lmao
 

·
Registered
Joined
·
13 Posts
horn, front park lights and blinkers FIXED/// the problem was a ground wire from steering column to computer [timp] beside batterie under hood. dealer spent few hrs trying to fig out. Had hidden broken ground. dealer ran new separate ground instead spending too much time finding break in wire. Dealer said solder joints break in wires, causes probs. dealer also said if you have a lot of miles with no probs with computer, you won't have any later on. i got 100000+
I have this exact same problem. I am wondering if you have some more info on the fix. I know if I take it to the dealer they are still going to spend hours troubleshooting... If you can post pics of the wire they installed and where it goes??? Id appreciate it....

Thanks
 

·
Registered
Joined
·
2 Posts
I am having the same exact problem as well. Does anyone know where I need to run this ground wire at the column and to the TIPM? Any help is appreciated
 

·
Registered
Joined
·
2 Posts
After tearing my hair out for a while I found the issue.. I am posting the video in case others find this thread during a search. My issues were exactly like the OP but in a 2008 JKU.
In the end, bad ground point.. will need to cut off the ring terminal and make a new one..

 

·
Registered
Joined
·
1 Posts
horn quit working/ ck 2 fuses looks ok.// also i have a problem w/right side front blinker park light. blinker will work but quits when i turn on park lights on. I read an earlier thread about multifunction switch in which might be the park light prob. //First post, hello to all
Check the ground behind the passenger headlight
 
1 - 17 of 17 Posts
Top