JKOwners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
At 7500 miles I lost my first engine. It kept dying and I kept starting it because no engine light and temp was fine. dum d dumm dumm, the darn thing was loosing oil pressure and I didn't find the readout till to late. While on a trail ride with 20 other jeeps and with 7500 on my second engine it started acting the same but I was ready for it. Once it died I checked the oil pressure and it was low, 8 psi, at idle. I have found that the 3.6 is ok with 5 psi smdh. Long story short, I changed the oil and filter with full syn and some lucas and was able to drive it 4 hrs to home. I will have to change a few tappets and while at it would like to add an oil cooler but havent found any on the market to bolt up to the crazy system they made.

Has anyone else had this issue with the 3.6? I think it has to do with the low psi these run at idle and the slow pace of crawling. I am currently waiting on Chrystler to contact me. Being that me engine is not under warrenty (long story that would piss off the pope) I am hoping they will want to know wth is going on too.. in the mean time I will take any advice you guys could give. 2015 JKU Rubi.
 

·
Registered
Joined
·
378 Posts
I have a 2015 JKUR. I have had zero issues with the 3.6. Snow, desert, high elevation, etc. Super smooth powerband, idles like a kitten. Probably one of the best engines I've ever had. Ive had 7.3PSD, 4.0,5.7...you name it. The pentastar is one slick motor. Oil change after break in is every 8k or whenever the oil life indicator goes off. Pennzoil platinum and a mopar filter.
 
1 - 2 of 2 Posts
Top