Another bad 2012 Pentastar - JKowners.com : Jeep Wrangler JK Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 379 Old 03-22-2012, 09:45 PM Thread Starter
Granite Guru
 
Join Date: Aug 2011
Age: 50
Posts: 108
Feedback: 0 reviews
Another bad 2012 Pentastar

You may remember that I had the ticking noise in my 2012 JKU. The dealership said the noise was normal, even going so far as to let me listen to several of the ones on their lot to show me they sounded the same. Well, tonight my MIL light comes on while sitting idling. Check the codes P0304 - misfire on #4 cylinder. So tomorrow I get to go in there and tell them that they need to pull the 2012's on their lot and get them into the service bays, AFTER they fix mine. I'm so f'n pissed right now I'm not really sure how I'm not going to just knock the crap out of someone if they don't bend over backwards. When I went in originally, I told them about what was being reported and exactly what was being done to fix it but they didn't listen to anything I told them.

So for those of you that have been through this, what is the average time to fix and are they putting you in a rental? (I don't do extended warranties)...

2012 Unlimited
dropped and locked, low and slow!

Last edited by Offcamber; 03-22-2012 at 09:53 PM.
Offcamber is offline  
Sponsored Links
Advertisement
 
post #2 of 379 Old 03-22-2012, 10:09 PM
Granite Guru
 
Trail Concepts's Avatar
 
Join Date: Feb 2012
Location: Coming Soon Prescott,Az
Age: 42
Posts: 469
Garage
Feedback: 1 reviews

I highly doubt you will get a rental unless you raise hell! The factory warranty does not cover them.

Jason

Jeep Sales/Adventure Jeep Packages/Parts
480-788-7245 or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Rock Krawler American Expedition Vehicles Poly Perfomance Spod RCV Performance Dynatrac Poison Spyder Customs Ripp Superchargers
Trail Concepts is offline  
post #3 of 379 Old 03-23-2012, 05:33 AM
Granite Guru
 
Join Date: Feb 2012
Posts: 147
Feedback: 0 reviews

They gave us a rental for the P0304 issue with no hassle whatsoever and we didn't have any kind of protection plan/extended warranty, or rental coverage they sell.

I'm guessing that you've read my thread already on our experience.

Demand a compression test and cylinder head inspection. Don't let the idiots tell you "that you have bad gas," apply the TSB, and send you on your way.

Sorry to hear that you're another victim. If you read the Wikipedia page on the Pentastar it sounds like a dream engine. But looking at the different HP ratings for all the different vehicles one might guess that the tweaking has gone bad...
Amatore is offline  
Sponsored Links
Advertisement
 
post #4 of 379 Old 03-23-2012, 05:42 AM
Rock God
 
Join Date: Aug 2011
Posts: 1,757
Feedback: 0 reviews

Mine also sounds like a ticking time bomb.

EX-Jersey
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Crew

Find us at www.disconnectedoffroad.com
dumptruckRich is offline  
post #5 of 379 Old 03-23-2012, 06:24 AM
JKO Addict!
 
e-jeep's Avatar
 
Join Date: Jan 2010
Location: Stuck walking up the down escalator
Posts: 5,713
Garage
Feedback: 12 reviews

1st year growing pains. Sorry to hear ...hope you get it all worked out.

My Build Thread ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

NE Trail Ride Thread ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Want Jeep Mods? Marcus Has It!! ~ River City Offroad
Adrenaline Offroad
~ Best Jeep shop in the Washington DC area!![/COLOR]
e-jeep is offline  
post #6 of 379 Old 03-23-2012, 08:45 AM Thread Starter
Granite Guru
 
Join Date: Aug 2011
Age: 50
Posts: 108
Feedback: 0 reviews

This is so damned frustrating. Dealership called a bit ago. I had told them that I wanted a compression test and head inspection. They say that Jeep's procedure is to apply the flash and have me drive it. If the code comes up again, they will investigate further. When I asked if the flash fixed the ticking they again state that the noise is normal. When I go back up there I'm probably going to lose it.


Quote:
Originally Posted by Amatore View Post
They gave us a rental for the P0304 issue with no hassle whatsoever and we didn't have any kind of protection plan/extended warranty, or rental coverage they sell.

I'm guessing that you've read my thread already on our experience.

Demand a compression test and cylinder head inspection. Don't let the idiots tell you "that you have bad gas," apply the TSB, and send you on your way.

Sorry to hear that you're another victim. If you read the Wikipedia page on the Pentastar it sounds like a dream engine. But looking at the different HP ratings for all the different vehicles one might guess that the tweaking has gone bad...

2012 Unlimited
dropped and locked, low and slow!
Offcamber is offline  
post #7 of 379 Old 03-23-2012, 09:35 AM
Rock God
 
Join Date: Sep 2009
Age: 38
Posts: 1,497
Feedback: 0 reviews

Quote:
Originally Posted by Offcamber View Post
This is so damned frustrating. Dealership called a bit ago. I had told them that I wanted a compression test and head inspection. They say that Jeep's procedure is to apply the flash and have me drive it. If the code comes up again, they will investigate further. When I asked if the flash fixed the ticking they again state that the noise is normal. When I go back up there I'm probably going to lose it.
id just blow it up, tow it in, then ask if they think they should have done the compression check after all?

2011 Cosmo blue Unlimited Sport- stock for now.
savage is offline  
post #8 of 379 Old 03-23-2012, 09:37 AM
JKO Addict!
 
Jaybee1669's Avatar
 
Join Date: Apr 2010
Location: Houston, TX
Age: 46
Posts: 2,507
Garage
Feedback: 2 reviews

a future youtube moment in the making.

I think this thing is finally coming together. Still Needed: drive shafts, frame mount rails...then done son! For a while...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jaybee1669 is offline  
post #9 of 379 Old 03-23-2012, 09:39 AM
Rock God
 
Join Date: Sep 2009
Age: 38
Posts: 1,497
Feedback: 0 reviews

Quote:
Originally Posted by Jaybee1669 View Post
a future youtube moment in the making.
yep might as well document what you can of it. maybe video the sound if you can etc.

2011 Cosmo blue Unlimited Sport- stock for now.
savage is offline  
post #10 of 379 Old 03-23-2012, 12:27 PM
Granite Guru
 
DynoGuy's Avatar
 
Join Date: Nov 2011
Location: Statesville, NC
Age: 55
Posts: 173
Feedback: 1 reviews

As some of you may already know I took mine in a month ago for them to look at because of the MIL light on and manual trans that took a dump, after a couple of weeks waiting for the trans to show they tryed to give me it back after just doing the flash but mine was so bad thatis has a shake while idling that could be felt in the cabin, I complain they look at it fine nothing wrong and send me on my merry way 10 miles later another code comes up, i take it back and the next day sure enough a bad head. It took a few days to get but then the head gasket that came with it was damaged so another couple of days. Jeep should have been done yesterday so i went over there to see what was up and come to find out that the cam phaser had broke while they were warming up after the install. best part is no phone call to inform me about problem and the parts are on back order with no idea when they will be availible. I had first dropped the Jeep off to them on Feb. 21st so today is day 31. I went in to speak to the service manager (who wasn't in last night and they didn't see fit to call me this morning to try and fix this ) and told him that they either replace the engine or get me a new Jeep. He has a call into the Chrysler rep and he'll have a decision on monday. So yes I feel your pain, as I told the S/M if they would have Diagnosed the problem at the very being as i had tryed to tell them this would have been a less of a problem for me as it looks like at least another week but most likely 2 before i get it back.
DynoGuy is offline  
post #11 of 379 Old 03-23-2012, 04:38 PM
Rock God
 
Join Date: Sep 2009
Age: 38
Posts: 1,497
Feedback: 0 reviews

Quote:
Originally Posted by DynoGuy View Post
As some of you may already know I took mine in a month ago for them to look at because of the MIL light on and manual trans that took a dump, after a couple of weeks waiting for the trans to show they tryed to give me it back after just doing the flash but mine was so bad thatis has a shake while idling that could be felt in the cabin, I complain they look at it fine nothing wrong and send me on my merry way 10 miles later another code comes up, i take it back and the next day sure enough a bad head. It took a few days to get but then the head gasket that came with it was damaged so another couple of days. Jeep should have been done yesterday so i went over there to see what was up and come to find out that the cam phaser had broke while they were warming up after the install. best part is no phone call to inform me about problem and the parts are on back order with no idea when they will be availible. I had first dropped the Jeep off to them on Feb. 21st so today is day 31. I went in to speak to the service manager (who wasn't in last night and they didn't see fit to call me this morning to try and fix this ) and told him that they either replace the engine or get me a new Jeep. He has a call into the Chrysler rep and he'll have a decision on monday. So yes I feel your pain, as I told the S/M if they would have Diagnosed the problem at the very being as i had tryed to tell them this would have been a less of a problem for me as it looks like at least another week but most likely 2 before i get it back.
reading this makes me feel WAY better about my '11. sorry man!

2011 Cosmo blue Unlimited Sport- stock for now.
savage is offline  
post #12 of 379 Old 03-24-2012, 05:01 AM
Granite Guru
 
Join Date: Feb 2012
Posts: 147
Feedback: 0 reviews
Where's The Parts?

Quote:
Compact and lightweight, Pentastar V-6 will be used in front-, rear- and all-wheel-drive models. Already standard on the new Jeep Grand Cherokee, the V-6 will gradually phase out seven V-6 legacy engines ranging from 2.7 liters, up to 4.0 liters in the current product portfolio. Overall, the new Pentastar will enable Chrysler Powertrain to reduce major engine components from 189 parts to just 32, greatly simplifying the build process and improving quality. Significant cost savings also are realized with purchasing efficiencies and a reduction in limited, high piece cost parts.

Some parts, including the exhaust manifolds, will completely disappear by virtue of being cast directly into the cylinder head. Today, the engine line-up features 32 different left and right exhaust manifolds. That will drop to zero with the new Pentastar V-6.

Upper and lower intake assembles, which accounted for 21 and 11 different parts numbers (respectively) have been reduced to two upper and lower assemblies. Camshaft variations will drop from 14 to four and just two fuel rails will be required rather than the current 14.
http://www.prnewswire.com/news-relea...105437573.html

And no parts in stock, huh?
Amatore is offline  
post #13 of 379 Old 03-24-2012, 09:54 AM
Rock God
 
lbeato's Avatar
 
Join Date: Aug 2009
Location: Miami, Fl
Age: 48
Posts: 719
Feedback: 0 reviews

Glad I found this thread, I'm curious if any of you with this issue noticed any type of drag in the engine anytime prior to getting the code. I noticed about a month ago after towing a buddy of mine that I get some drag in my engine at low rpms.

2012 SLV JK Unlimited Rubicon
lbeato is offline  
post #14 of 379 Old 03-24-2012, 11:29 AM
Rock God
 
owtdorz's Avatar
 
Join Date: Mar 2009
Location: Ahwatukee, AZ
Age: 54
Posts: 1,340
Feedback: 0 reviews

3.6 growing pains are:
Cam phasers (second year problem)

Cylinder heads
Aftermarket oil filters
I LOVE my '09

'09 4dr Rubi Detonator Yellow
35x12.5x17 BFG KM2s they SUCK!
Rugged Ridge XHD bumper Warn 9.5ti
3.5 Mid arm Rock Krawler
Finally 5.13s
owtdorz is offline  
post #15 of 379 Old 03-24-2012, 04:25 PM
Wheeler
 
Join Date: Sep 2009
Location: Ontario, Canada.
Age: 35
Posts: 99
Feedback: 0 reviews

Quote:
Originally Posted by owtdorz View Post
3.6 growing pains are:
Cam phasers (second year problem)

Cylinder heads
Aftermarket oil filters
I LOVE my '09
You won't love your '09 when the TIPM takes a dump
Menard666 is offline  
post #16 of 379 Old 03-25-2012, 09:46 AM
Rock God
 
jkdrone's Avatar
 
Join Date: Jun 2008
Location: Houston, TX
Posts: 712
Garage
Feedback: 0 reviews

Quote:
Originally Posted by Menard666 View Post
You won't love your '09 when the TIPM takes a dump
Yeah, good luck getting one. (It wasn't much fun in the '08 either.)

!c
jkdrone is offline  
post #17 of 379 Old 03-25-2012, 10:22 AM
Wheeler
 
Join Date: Mar 2012
Location: Denver, Colorado
Posts: 58
Feedback: 0 reviews

So what exactly is the problem with the heads? It sounds like something is causing a loss of compression, but I have not herd any root cause? Valves bending? Gasket issues? If anyone has specifics, I would be very interested to hear about it.

Pete
Crush Sport is offline  
post #18 of 379 Old 03-25-2012, 10:45 AM
R.I.P. Mr. Nibbles!
 
JKCTAZ's Avatar
 
Join Date: Apr 2011
Location: AZ
Age: 44
Posts: 8,953
Feedback: 2 reviews

Quote:
Originally Posted by owtdorz View Post
3.6 growing pains are:
Cam phasers (second year problem)

Cylinder heads
Aftermarket oil filters
I LOVE my '09
I was wondering if you were going to add to this. I remember you talking to Jason about this at the burger place after the Pavillions a while back.

Quote:
Originally Posted by braindead0 View Post
Some folks are fine with being screwed over, perhaps finding confrontation to be more stressful than just living with whatever the problem is. These are excellent consumers, manufactured to the finest specifications.
Reformed Jeep addict... Jeepless for now.
JKCTAZ is offline  
post #19 of 379 Old 03-25-2012, 06:09 PM
Granite Guru
 
DynoGuy's Avatar
 
Join Date: Nov 2011
Location: Statesville, NC
Age: 55
Posts: 173
Feedback: 1 reviews

Quote:
Originally Posted by Crush Sport View Post
So what exactly is the problem with the heads? It sounds like something is causing a loss of compression, but I have not herd any root cause? Valves bending? Gasket issues? If anyone has specifics, I would be very interested to hear about it.

Pete
Pete I have my idea on what caused my issue with the cylinder head but I haven't seen the bad parts nor talked to the tech about what they had found so I'll hold off on my comment till later.
DynoGuy is offline  
post #20 of 379 Old 03-27-2012, 04:08 PM Thread Starter
Granite Guru
 
Join Date: Aug 2011
Age: 50
Posts: 108
Feedback: 0 reviews

Took mine back in this morning. Needs new heads. They started the work this afternoon and it should be ready tomorrow. They said since there are so many 2012's with this issue they have made lots of spares available....

2012 Unlimited
dropped and locked, low and slow!
Offcamber is offline  
post #21 of 379 Old 03-27-2012, 05:08 PM
Granite Guru
 
Join Date: Feb 2012
Posts: 147
Feedback: 0 reviews

Quote:
Originally Posted by Offcamber View Post
Took mine back in this morning. Needs new heads. They started the work this afternoon and it should be ready tomorrow. They said since there are so many 2012's with this issue they have made lots of spares available....
They changed one head on mine and said it took 20 hours. The tech said he basically had to strip the engine of timing cover, oil pan, A/C etc.

How are they doing yours that quick?

Or are they just becoming "that experienced" on this issue?

I'm really surprised the media is yet to pick up on this issue. It's to the point of "I'm here for my first 8,000 mile oil and head change."

Amatore is offline  
post #22 of 379 Old 03-27-2012, 05:27 PM
Granite Guru
 
Join Date: Feb 2012
Posts: 147
Feedback: 0 reviews

Quote:
Originally Posted by Ditch55 View Post
What is the build date? Mine is 12-23-11 are the heads you have made in Mexico? This is pissing me off after spending so much money. I am not being selfish, I understand and wish us all the best! With are state of the art 3.6 Pentastar......I hope I can sleep tonight?

Damn it!!!
My build date was August 28, 2011.
Amatore is offline  
post #23 of 379 Old 03-27-2012, 05:28 PM
Granite Guru
 
DynoGuy's Avatar
 
Join Date: Nov 2011
Location: Statesville, NC
Age: 55
Posts: 173
Feedback: 1 reviews

So here is my update. Dealer called me yesterday and said that the Chrysler rep had gotten a new camshaft to them and they were going to remove the oil pan & front cover to make sure all debris was cleaned out and should be completed today. Got the call this afternoon and all is good, they are going to clean it up in the morning and be ready for pick up at lunch. This was day 36 since I dropped it off. From my understanding of what happened with the camshaft/phase problem I don,t see how it didn't bend any valves from either contact with a piston or contact to the exhaust valve. Service director said it runs great so we'll see. I just wish the dealer that I first took this to while I was out at KOH would have had the proper adaptor to do the compression test. They were on the right track when trying to solve the problem instead of just doing the ECU update that is a joke. I'm sure glad I had to use the money on closing of the new house instead of having Marcus get me that lift kit that I was a day away from ordering, I bet this would had been worse trying to get all of this fixed with that lift.
DynoGuy is offline  
post #24 of 379 Old 03-27-2012, 05:34 PM
Granite Guru
 
Join Date: Feb 2012
Posts: 147
Feedback: 0 reviews

Quote:
Originally Posted by DynoGuy View Post
So here is my update. Dealer called me yesterday and said that the Chrysler rep had gotten a new camshaft to them and they were going to remove the oil pan & front cover to make sure all debris was cleaned out and should be completed today. Got the call this afternoon and all is good, they are going to clean it up in the morning and be ready for pick up at lunch. This was day 36 since I dropped it off. From my understanding of what happened with the camshaft/phase problem I don,t see how it didn't bend any valves from either contact with a piston or contact to the exhaust valve. Service director said it runs great so we'll see. I just wish the dealer that I first took this to while I was out at KOH would have had the proper adaptor to do the compression test. They were on the right track when trying to solve the problem instead of just doing the ECU update that is a joke. I'm sure glad I had to use the money on closing of the new house instead of having Marcus get me that lift kit that I was a day away from ordering, I bet this would had been worse trying to get all of this fixed with that lift.
Hopefully it'll be alright, but you're a better man than me: day 36, they'd either have to have a new set of keys or a check made out to my lender...
Amatore is offline  
post #25 of 379 Old 03-27-2012, 06:08 PM Thread Starter
Granite Guru
 
Join Date: Aug 2011
Age: 50
Posts: 108
Feedback: 0 reviews

Mines lifted 3.5" and they haven't said a word about it.


Quote:
Originally Posted by DynoGuy View Post
So here is my update. Dealer called me yesterday and said that the Chrysler rep had gotten a new camshaft to them and they were going to remove the oil pan & front cover to make sure all debris was cleaned out and should be completed today. Got the call this afternoon and all is good, they are going to clean it up in the morning and be ready for pick up at lunch. This was day 36 since I dropped it off. From my understanding of what happened with the camshaft/phase problem I don,t see how it didn't bend any valves from either contact with a piston or contact to the exhaust valve. Service director said it runs great so we'll see. I just wish the dealer that I first took this to while I was out at KOH would have had the proper adaptor to do the compression test. They were on the right track when trying to solve the problem instead of just doing the ECU update that is a joke. I'm sure glad I had to use the money on closing of the new house instead of having Marcus get me that lift kit that I was a day away from ordering, I bet this would had been worse trying to get all of this fixed with that lift.

2012 Unlimited
dropped and locked, low and slow!
Offcamber is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome