Bushwacker Flat Fender - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 06-12-2011, 06:25 AM Thread Starter
Wheeler
 
gerdyj's Avatar
 
Join Date: Aug 2010
Location: Independence, MO
Age: 42
Posts: 64
Feedback: 0 reviews
Question Bushwacker Flat Fender

Is anyone having issues with the rubber trim sticking to the body? I've had mine on for about 4 months, and it seems to be getting worse. It's not a huge deal, but for what I paid they shouldn't be doing that. Just curious if anyone else was having the same issue.
gerdyj is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 06-12-2011, 07:18 AM
Rock God
 
jkruss's Avatar
 
Join Date: Jan 2009
Location: new jersey
Age: 47
Posts: 1,840
Garage
Feedback: 0 reviews

Yup, I be honest I am not real happy with them.

Black Jeep
jkruss is offline  
post #3 of 17 Old 06-12-2011, 07:24 AM Thread Starter
Wheeler
 
gerdyj's Avatar
 
Join Date: Aug 2010
Location: Independence, MO
Age: 42
Posts: 64
Feedback: 0 reviews

Yeah me either. I really don't see the purpose of the rubber trim, the Xenons don't have it.
gerdyj is offline  
Sponsored Links
Advertisement
 
post #4 of 17 Old 06-12-2011, 08:35 AM
Granite Guru
 
Join Date: Apr 2010
Location: Benton, AR
Age: 40
Posts: 437
Feedback: 0 reviews

Are you griping about them sticking to the body (which they are supposed to do) or griping about them pulling away from the body? Mine have been on about three months now and still are stuck ok to the body.

2007 Rescue Green 2-door
A few mods here and there
jgkjeep is offline  
post #5 of 17 Old 06-12-2011, 08:55 AM Thread Starter
Wheeler
 
gerdyj's Avatar
 
Join Date: Aug 2010
Location: Independence, MO
Age: 42
Posts: 64
Feedback: 0 reviews

It's actually pulling away from body. It wasn't like that to begin with, just over the last few months I've started noticing it.
gerdyj is offline  
post #6 of 17 Old 06-12-2011, 10:44 AM
Granite Guru
 
Join Date: Apr 2010
Location: Benton, AR
Age: 40
Posts: 437
Feedback: 0 reviews

Quote:
Originally Posted by gerdyj View Post
It's actually pulling away from body. It wasn't like that to begin with, just over the last few months I've started noticing it.
yuck that sucks

I have some big gaps between the fender and sheetmetal right now. Might have to do with hitting some trees though.

2007 Rescue Green 2-door
A few mods here and there
jgkjeep is offline  
post #7 of 17 Old 06-12-2011, 11:05 AM Thread Starter
Wheeler
 
gerdyj's Avatar
 
Join Date: Aug 2010
Location: Independence, MO
Age: 42
Posts: 64
Feedback: 0 reviews

Yeah I haven't hit mine on anything. If they weren't so expensive I wouldn't care, but for as much money as I forked over, they should be perfect.
gerdyj is offline  
post #8 of 17 Old 06-12-2011, 03:11 PM
JKO Addict!
 
bnb2010's Avatar
 
Join Date: Nov 2010
Location: Plano, TX
Posts: 2,276
Feedback: 0 reviews

Mine r doing the same.


Sent from my smoke signals
bnb2010 is offline  
post #9 of 17 Old 06-12-2011, 03:19 PM
JKO Addict!
 
SONIC's Avatar
 
Join Date: Feb 2008
Location: Bell Buckle, TN
Posts: 3,730
Feedback: 1 reviews

Anyone have pictures?
And you didnt spend that much on them lol they are fairly cheap for flatties.

Yes, but there's just something about him. Something around the eyes, I don't know, reminds me of... me. No. I'm sure of it, I hate him.
-Doc Holiday
Why are you highlighting my sig? You Bastard!
SONIC is offline  
post #10 of 17 Old 06-12-2011, 03:26 PM
Rock God
 
owtdorz's Avatar
 
Join Date: Mar 2009
Location: Ahwatukee, AZ
Age: 55
Posts: 1,340
Feedback: 0 reviews

Mine have been on for about 1 1/2 years.
What it sounds like is the fender liner was not trimmed enough or properly and is pushing the fender away from the body.
Did everybody test fit them before applying the tape?

'09 4dr Rubi Detonator Yellow
35x12.5x17 BFG KM2s they SUCK!
Rugged Ridge XHD bumper Warn 9.5ti
3.5 Mid arm Rock Krawler
Finally 5.13s
owtdorz is offline  
post #11 of 17 Old 06-12-2011, 04:19 PM
Granite Guru
 
toolmanTim's Avatar
 
Join Date: Nov 2009
Location: CT
Age: 46
Posts: 303
Garage
Feedback: 0 reviews

All In the prep. When I did mine I made sure every mounting strip was flat and flush and the bolts sitting perfectly in their holes and nice and tight. Then prepped the body with alcohol a couple times over (Fenders too) and laid on the rubber seal. Shoved them on hard and peeled the strip and shoved them on harder and screwed them in. Been mint through the heat and cold ... not a budge.

'10 Surf 2Door Rubicon

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'01
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<-Vid Flexin' Muscle

6.2 liter Motec Ls swapped 2011 Jku with Rock Jock 60, Dynatrac rcv Pr44, and usual other beef on 37" MTR's.
toolmanTim is offline  
post #12 of 17 Old 06-12-2011, 04:25 PM
Rock God
 
coilrod's Avatar
 
Join Date: Feb 2010
Location: Lower mainland
Age: 52
Posts: 1,662
Garage
Feedback: 0 reviews

Mine pulled away slightly after I side swiped a tree. The branch dented the sheet metal first, then a tap to the rear quarter. I still really like them.
coilrod is offline  
post #13 of 17 Old 06-12-2011, 04:27 PM Thread Starter
Wheeler
 
gerdyj's Avatar
 
Join Date: Aug 2010
Location: Independence, MO
Age: 42
Posts: 64
Feedback: 0 reviews

I didn't install mine, my local 4x4 shop did. I don't have a garage, and it was cold outside when I purchased them. I trust that shop completely, they've been in business for over 20 years, and do lots of custom fab work, so I know they can handle a simple flare install.
gerdyj is offline  
post #14 of 17 Old 06-12-2011, 04:38 PM Thread Starter
Wheeler
 
gerdyj's Avatar
 
Join Date: Aug 2010
Location: Independence, MO
Age: 42
Posts: 64
Feedback: 0 reviews

Quote:
Originally Posted by SONIC View Post
Anyone have pictures?
And you didnt spend that much on them lol they are fairly cheap for flatties.
Hey, those things are pretty pricey for a piece of plastic.
gerdyj is offline  
post #15 of 17 Old 06-12-2011, 06:11 PM
Granite Guru
 
Join Date: Apr 2010
Location: Benton, AR
Age: 40
Posts: 437
Feedback: 0 reviews

Quote:
Originally Posted by owtdorz View Post
Mine have been on for about 1 1/2 years.
What it sounds like is the fender liner was not trimmed enough or properly and is pushing the fender away from the body.
Did everybody test fit them before applying the tape?
lol I just ripped my fender liners out and threw them away.

I did make sure everything lined up. It was a complete PITA to do but my kid can stand on them no problem when he climbs in and out of the back seat.

If they pull away and get horrible I will probably just pull them off and run without fenders.

2007 Rescue Green 2-door
A few mods here and there
jgkjeep is offline  
post #16 of 17 Old 06-12-2011, 07:08 PM
Rock God
 
Tail Rated's Avatar
 
Join Date: Feb 2009
Location: Aurora CO
Posts: 1,289
Feedback: 0 reviews

Yeah, I too had issues with those rubber strips. Without them, that plastic is rubbing into your paint for sure. Bushwacker sent me a new set @ N/C that I had re-installed. I will have to see if the current owner of the rig is having issues/ success with them.

2016 JKU
Tail Rated is offline  
post #17 of 17 Old 06-12-2011, 09:37 PM
Granite Guru
 
charles's Avatar
 
Join Date: Feb 2010
Location: Denver
Age: 38
Posts: 327
Feedback: 0 reviews

Mine are still stuck on after a full winter in Colorado. I think, as it was already said, in the prep work. The paint has to be clean. Preparation is always key anytime adhesives are used.
charles is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome