Transmission shifting issues - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 03-18-2019, 12:37 PM Thread Starter
Wheeler
 
Join Date: Apr 2016
Location: Valencia CA
Posts: 30
Feedback: 0 reviews
Transmission shifting issues

So I have a 2016 JKU 3.6L with Automatic with SD axles and 40" tires. I have all 4 speed sensors hooked up and reprogrammed taking into account the tooth count ratio. Drives and runs perfectly, speedo spot on.

Last few wheeling trips, I have had issues when in 4 low in particular but I think maybe 4 hi too, where the transmission stops shifting. When this happens I can't control the shifts manually, but I can shift to neutral, reverse park etc.

I can fix this by turning the jeep off and back on. This happened to me this weekend, no codes were thrown, no warning lights ever went on... Any suggestions? I think mine is still under warranty but I always hesitate to take it to the dealer with the heavy mods to the suspension...
cobaltis is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 03-21-2019, 08:47 PM
Wheeler
 
JGzCrush's Avatar
 
Join Date: Apr 2016
Posts: 19
Feedback: 0 reviews

When I did the swap I had similar issues. Particularly in 4 low. But occasionally it would go into limp mode normal driving giving me only 3rd gear.

I am assuming youíre using 60 tooth tone rings to match the SD unit bearings.

Find the percentage difference. I donít recall the tooth count stock jk but divide that number by 60. Youíll get .86 if I recall.

Take your gear ratio multiply by that percentage in my case 5.38 x .86 = 4.63 and my 40ís measure 38 x .86 = 32.68 (32.75) and itís all happy.
JGzCrush is offline  
post #3 of 8 Old 03-31-2019, 08:35 PM Thread Starter
Wheeler
 
Join Date: Apr 2016
Location: Valencia CA
Posts: 30
Feedback: 0 reviews

I did that, once I made those changes everything ran fine and stopped throwing codes except for this remaining issue when in 4 LOW. It just stops shifting gears. I can shift to neutral, reverse etc, but it will stick in say second, and not shift up or down until I restart the jeep?
cobaltis is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 03-31-2019, 08:38 PM
Wheeler
 
JGzCrush's Avatar
 
Join Date: Apr 2016
Posts: 19
Feedback: 0 reviews

Quote:
Originally Posted by cobaltis View Post
I did that, once I made those changes everything ran fine and stopped throwing codes except for this remaining issue when in 4 LOW. It just stops shifting gears. I can shift to neutral, reverse etc, but it will stick in say second, and not shift up or down until I restart the jeep?


Is it possible, the low range ratio isnít set correctly?

when I switched my t case, I didnít know the computer needed to know I changed it.
JGzCrush is offline  
post #5 of 8 Old 04-01-2019, 12:12 PM
Wheeler
 
obajoba's Avatar
 
Join Date: Apr 2016
Location: Denver
Posts: 52
Feedback: 0 reviews

Quote:
Originally Posted by JGzCrush View Post
Is it possible, the low range ratio isnít set correctly?

when I switched my t case, I didnít know the computer needed to know I changed it.
^^This. I purchased a tuned TCM and mine would freak out in 4L only. I ultimately ended up returning the TCM but I am fairly certain the issue was that the 4:1 option was missed in the tune. My inTune device was telling me the error was: PCM:P0732 Gear 2 Incorrect Gear Ratio Selected
obajoba is offline  
post #6 of 8 Old 04-01-2019, 07:24 PM
Granite Guru
 
Join Date: Mar 2008
Posts: 327
Feedback: 4 reviews

I just had this issue with my hemi swapped jku. Ended up being a faulty tcm


Sent from my iPhone using Tapatalk
Redrockjeepin is offline  
post #7 of 8 Old 04-01-2019, 07:27 PM
Wheeler
 
JGzCrush's Avatar
 
Join Date: Apr 2016
Posts: 19
Feedback: 0 reviews

I had a buddy that had similar issues too. His turned out to be an aftermarket stereo head unit that freaked out the can-bus system.
JGzCrush is offline  
post #8 of 8 Old 04-09-2019, 03:51 PM Thread Starter
Wheeler
 
Join Date: Apr 2016
Location: Valencia CA
Posts: 30
Feedback: 0 reviews

I havent changed my transfer case, still the stock 4:1, I can try to reprogram, otherwise maybe it is the TCM...
cobaltis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fix Your Shifting Issues! New OST TCM's Ready To ship! ostmike Vendor's Marketplace 0 01-16-2019 11:14 AM
2013 JK Shifting issues... medictrode JK General Discussion 4 08-29-2016 11:40 PM
'13 JKU Auto Transmission Shifting Issues David M Modified JK Tech Dept. 6 12-05-2014 11:55 PM
Tranny shifting issues captjay Modified JK Tech Dept. 11 09-07-2011 02:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome