Jk Transmission mount - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-28-2017, 11:52 AM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 1
Feedback: 0 reviews
Jk Transmission mount

Hello Everyone. New to the forum but have been using it for help troubleshooting. I have a 2013 JK unlimited and noticed the trans mount (Auto) seems loose but cannot find a part for this anywhere and was wondering if it was causing the clunk i hear when starting out form a dead stop. Thanks
Chris Hlentzas is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-28-2017, 12:51 PM
JKowners Vendor
 
Fusion 4x4's Avatar
 
Join Date: Feb 2016
Location: Metro Detroit
Posts: 444
Feedback: 0 reviews

Highly unlikely any part of the mounting system is loose, but what is it that makes you think that? The trans and engine are mounted on rubber isolators, so you should be able to move it around by hand a bit. Even if it were loose, I can't imagine what would cause the clunk. Maybe the exhaust is hitting something, such as a skid?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Fusion 4x4 is offline  
post #3 of 5 Old 03-28-2017, 12:59 PM
Rock God
 
j-rod17's Avatar
 
Join Date: Feb 2012
Location: Farmington WV
Age: 38
Posts: 1,520
Feedback: 4 reviews

or a CV on driveshaft?

2008 JKU: continual work in progress
j-rod17 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 03-28-2017, 02:15 PM
Rock God
 
ChuckTheRipper's Avatar
 
Join Date: Mar 2014
Location: Chester, WV
Age: 27
Posts: 925
Feedback: 0 reviews

Or a loose/ worn control arm bushing.


Sent from my iPhone using Tapatalk
ChuckTheRipper is offline  
post #5 of 5 Old 03-28-2017, 02:40 PM
Granite Guru
 
sprockwell's Avatar
 
Join Date: Apr 2013
Location: So. CA
Posts: 253
Feedback: 1 reviews

^^^ This. Check that your control arm bolts are tight.
sprockwell is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome