Steering issues? - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-10-2017, 04:53 PM Thread Starter
Newbie
 
Join Date: May 2016
Posts: 6
Feedback: 0 reviews
Steering issues?

Running 38x14.5's on a 2015 JK and a while back noticed the steering wheel was ridiculously difficult to turn while sitting in still at idle on rough blacktop. Revving up was not really much help, it was so bad my wife actually could not turn the wheel. If the vehicle is on a smother surface like a garage floor or moving at all, the steering works very easy as you would expect. The only other possible info that may be relevant is the front axle was switched to a Dana 60. I have installed a complete PSC system which works great, The reason for the question is I have a friend that wants the old box and I don't want to give it to him if it could be a problem for him.
Super Macho is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-10-2017, 06:09 PM
JKO Addict!
 
ALASHA's Avatar
 
Join Date: Oct 2009
Location: Denver, CO
Posts: 8,227
Feedback: 0 reviews

I am confused. You had a steering issue as described. You then upgraded to a 60 and a complete PSC system so now no problems. Is that correct?

Did you pull the old box and pump off? Im leaning towards a blown pump as a guess for the cause...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ALASHA is offline  
post #3 of 4 Old 01-10-2017, 07:42 PM
Rock God
 
Tweak's Avatar
 
Join Date: Jul 2013
Location: Whidbey Island, WA
Age: 31
Posts: 570
Feedback: 0 reviews

The pump was the likely culprit.

Billet 2013 2 door
Dana 60 front, 14 Bolt rear, ARB's, 5.38's, 40" sticky Trepadors, 3 link front and rear, 14" Sway-a-Way coilovers, Tom Woods 1310 front, Adams 1350 rear, PSC Hydro assist
Tweak is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 01-10-2017, 08:40 PM
Granite Guru
 
Join Date: May 2013
Posts: 188
Feedback: 0 reviews

I would replace the fluid first. If there's no change, the pump might not just throwing enough fluid at idle.
karlduke is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome