ARB Tire valve fitting issue - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-27-2010, 11:09 AM Thread Starter
The Flower Guy
 
Tagg's Avatar
 
Join Date: Nov 2008
Location: Calgary, AB
Posts: 118
Feedback: 0 reviews
ARB Tire valve fitting issue

Has any one else had problems with the ARB fitting that attaches to the tire valve? On mine the little tab on the end falls off when the clip is pressed open. Just wondering what the solution is? Any comments are welcome. So far I've only dropped it on pavement but on the trail I'm not sure I would be able to find it.

Jim
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tagg is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome