Steering box/pump going bad?? I have a recording of it. - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-05-2012, 10:03 PM Thread Starter
Wheeler
 
Join Date: Jan 2012
Age: 33
Posts: 10
Feedback: 0 reviews
Steering box/pump going bad?? I have a recording of it.

Hello all! I have this intermittent grinding noise coming from what i assume is the steering pump/box. At first i thought it while in motion and turning the wheel to the left but its very intermittent and i actually noticed it did it today while motionless. It only happens when turning the wheel to the left and when the noise starts, it goes away if i keep the wheel turning or if i release the wheel and let it center. The noise will stay if i hold it in that position, but if i release the wheel and go back to the position that was previously making noise its silent! I'm stumped on this one.

the dealers down here a real pain in the ass so I'm trying to avoid going there if at all possible. I have checked fluid levels and made sure the reservoir is not clogged up with junk. Its a 2010 rubicon with a 2.5" Teraflex lift and 35's. I recorded a video of it if you have 20 seconds please check it out and input any advice. Thanks again everyone.

Steering pump going bad? - YouTube
Jeep505 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome