Idle - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 12-12-2011, 12:03 PM Thread Starter
Wheeler
 
thejkwith9lives's Avatar
 
Join Date: Jul 2011
Location: H-Town ,TX
Posts: 19
Feedback: 0 reviews
Idle

My 07 JK drops in RPM's and sort of shakes but not bad at a idle. It doesnt happen very often. My JK has 18k miles and has had a recent oil change. I just got it while i was deployed to Afghanistan so ive only drove it 800 miles since ive had it back in May. Have no idea if previous owner has done tune-up or anything. Jeep hasnt been abused there are no scraps or dings, rust or even a slight hint of mud. Dont think it was due to anbuse but maybe it needs new spark plugs?. Also there is no noises associated when the RPM's drop just the slight shudder of the engine. I fix it by reving the RPM a couple of times and it goes away. Any ideas.

07 2DR Rubi-tastic
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OME LT KIT
35'' Nitto's
Smittybuilt Fenders
18'' KMC Addicts
PSC Brawler lite F/R Bumpers
MBRP Cat-Back exhaust
Superchipped
Warn m8000

Last edited by thejkwith9lives; 12-12-2011 at 12:08 PM.
thejkwith9lives is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-12-2011, 12:10 PM
Rock God
 
Daniel_M's Avatar
 
Join Date: Jan 2011
Location: Arizoner
Age: 35
Posts: 998
Garage
Feedback: 0 reviews

Mine does this only on start up after it cooled down for a while. After a few seconds it drops down to idle RPM range (500-800 RPM) and idles like a church mouse after.

-Dan

2008 JK X: Sold
Daniel_M is offline  
post #3 of 7 Old 12-12-2011, 12:12 PM Thread Starter
Wheeler
 
thejkwith9lives's Avatar
 
Join Date: Jul 2011
Location: H-Town ,TX
Posts: 19
Feedback: 0 reviews

Yeah mine will do it after an hour or so of driving. Ive never noticed it on startup

07 2DR Rubi-tastic
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OME LT KIT
35'' Nitto's
Smittybuilt Fenders
18'' KMC Addicts
PSC Brawler lite F/R Bumpers
MBRP Cat-Back exhaust
Superchipped
Warn m8000
thejkwith9lives is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 12-12-2011, 12:21 PM
JKO Addict!
 
Goodysgotacuda's Avatar
 
Join Date: May 2009
Location: Denton, TX
Posts: 13,230
Feedback: 1 reviews

Mine does it as well at 44k. I notice the torque at idle being lower (easier to notice on a manual). I plan on cleaning the throttle body and swapping plugs, see how it does.

SOLD - '09 2dr Rubicon - 1.0Gal | 6spd | 37s | 4.88s |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| OR-Fab cage | Poly Cage | BFH Front | XRC Rear | XRC12 Winch | Walker Evans Beadlocks |

Retired from the Jeep community, for now.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Goodysgotacuda is offline  
post #5 of 7 Old 12-12-2011, 12:24 PM Thread Starter
Wheeler
 
thejkwith9lives's Avatar
 
Join Date: Jul 2011
Location: H-Town ,TX
Posts: 19
Feedback: 0 reviews

I might do the same when i get home. Maybe some Seafoam?

07 2DR Rubi-tastic
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OME LT KIT
35'' Nitto's
Smittybuilt Fenders
18'' KMC Addicts
PSC Brawler lite F/R Bumpers
MBRP Cat-Back exhaust
Superchipped
Warn m8000
thejkwith9lives is offline  
post #6 of 7 Old 12-12-2011, 02:11 PM
JKO Addict!
 
Goodysgotacuda's Avatar
 
Join Date: May 2009
Location: Denton, TX
Posts: 13,230
Feedback: 1 reviews

Quote:
Originally Posted by thejkwith9lives View Post
I might do the same when i get home. Maybe some Seafoam?
With 18,000 miles I doubt plugs or carbon (what seafoam deals with) is your problem. BUT I have not seen it all!

SOLD - '09 2dr Rubicon - 1.0Gal | 6spd | 37s | 4.88s |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| OR-Fab cage | Poly Cage | BFH Front | XRC Rear | XRC12 Winch | Walker Evans Beadlocks |

Retired from the Jeep community, for now.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Goodysgotacuda is offline  
post #7 of 7 Old 12-12-2011, 02:34 PM
Granite Guru
 
Join Date: Dec 2008
Location: Boise, ID
Age: 33
Posts: 382
Feedback: 1 reviews
Send a message via AIM to srbaker2 Send a message via MSN to srbaker2 Send a message via Yahoo to srbaker2

Mine used to do it and I tried every type of gas treatment and seafoam through the brake booster line nothing worked until I pulled the throttle body off and cleaned it I also replaced the spark plugs and plug wires
srbaker2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome