stupid effin' gascap light!!! - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 10-26-2011, 08:38 PM Thread Starter
Granite Guru
 
Lt. Dan's Avatar
 
Join Date: Nov 2010
Age: 43
Posts: 253
Feedback: 0 reviews
stupid effin' gascap light!!!

So rock crawling a couple weeks ago, I ripped off the EVAP cannister... Of course, the "gascap" light came on.. Well, new cannister, valve on the cannister, and seal.... Light still on... New gascap... light still on.... Where do I check next?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Where the cool kids in VA hang out!!

Military? Got a Jeep?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lt. Dan is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-26-2011, 08:51 PM
Rock God
 
snowbilt's Avatar
 
Join Date: Sep 2010
Location: Oklahoma City, OK
Posts: 572
Feedback: 0 reviews

Have you cleared the codes?
snowbilt is offline  
post #3 of 8 Old 10-26-2011, 09:12 PM
Rock God
 
jacktuttle's Avatar
 
Join Date: Aug 2008
Location: Fullerton, CA
Age: 62
Posts: 1,452
Garage
Feedback: 0 reviews
Lightbulb codes

If you do not have a obdII code reader to reset the code then disconnect the negative battery terminal for a couple of minutes. Often times that will reset the codes too.

Paved Roads - Another Fine Example of Unnecessary Government Waste!
Modes - 3.5" Lift - Steel Jeep Bumper with Winch. Body Armor 4x4 Rear Bumper and Rock Sliders. - Hard Top painted White to repel the HEAT! - Ham\CB Radio - A few dents and Scratches John Bull Mod to Front & Rear Diff Covers. Woods Steering Stabilizer Relocation Bracket. Off-road Front, Rear and Rock Lights, Rear CAM, On Board Air.
jacktuttle is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 10-26-2011, 09:23 PM
Rock God
 
scrogg's Avatar
 
Join Date: Apr 2008
Location: Utah
Posts: 899
Garage
Feedback: 0 reviews

I had a similar issue, broke it up pretty good and had it replaced. And the light kept coming on after the new one was installed. It turned out I was missing the o-ring on the littler part that plugs into the canister.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
scrogg is offline  
post #5 of 8 Old 10-26-2011, 09:48 PM
Rock God
 
Join Date: Mar 2010
Location: FWD, TX
Age: 31
Posts: 660
Feedback: 0 reviews

Check your hoses going into the canister, if any of them are kinked it'll cause the light to come on.
HOT_DAMN is offline  
post #6 of 8 Old 10-30-2011, 04:58 PM Thread Starter
Granite Guru
 
Lt. Dan's Avatar
 
Join Date: Nov 2010
Age: 43
Posts: 253
Feedback: 0 reviews

took some time with it today... took apart the lines, cleaned and checked as best I could for leaks... then on all the press fittings I used hose clamps for extra insurance... Re-set the light.. Hopefully that will fix it...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Where the cool kids in VA hang out!!

Military? Got a Jeep?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lt. Dan is offline  
post #7 of 8 Old 10-31-2011, 08:14 AM
Rock God
 
LILWB's Avatar
 
Join Date: Aug 2010
Location: Long Island, NY
Age: 42
Posts: 1,043
Feedback: 2 reviews

I've had a similar problem. Make sure you have the green o-ring between the canister and the white valve thing.
I installed the o-ring and used rvt along with hose clamps to make sure it was all tight and still got the gas cap light.
One thing that has helped so far, believe it or not, I replaced the PCV valve with a NAPA part. This was supposed to help with oil blowing by the rings but my gas cap and general "evap system failure" codes have stopped.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 JKUR- 3 Inch Synergy Stage III Lift, PR44, 1310 Shafts, RROR Skids, 37" MTR's, Warn 9.5Ti, Bumpers, Sliders, OBA, Lights... bla bla bla
LILWB is offline  
post #8 of 8 Old 11-16-2011, 08:57 PM
Granite Guru
 
SANDBLAST XTREME's Avatar
 
Join Date: Oct 2011
Location: Wildomar, CA
Age: 49
Posts: 104
Feedback: 0 reviews

FYI - my original locking gas cap broke and I replace it with an Autozone cap. Gas light kept coming on, finally went to the stealership and purchased a $25 non-locking cap...problem solved!

2007 Rubicon JKU - Sandstone
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SANDBLAST XTREME is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome