Just had my first CANBUS gremlin experience - JKowners.com : Jeep Wrangler JK Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 28 Old 12-05-2008, 09:10 PM Thread Starter
JKO Addict!
 
venom's Avatar
 
Join Date: Sep 2007
Location: East of Abilene, TX
Posts: 6,381
Garage
Feedback: 0 reviews
Send a message via Skype™ to venom
Just had my first CANBUS gremlin experience

I've read all the horror stories about weirdness cause by the computer and I've never had a bit of trouble so I haven't messed with it - didn't even get the K40 recall done since it involves a reflash and I didn't want to take a chance.
Anyway tonight was a minor weirdness....
While I was walking out to the Jeep, I hit unlock on the fob to trigger the headlights get some illumination.
When I got to it, the radio was playing.
when I opened the door it cut just like its supposed to do when you shut the Jeep off, how it keeps playing till you open the door.
Didn't do it again,just the one time.

Hope this isnt a sign of things to come......


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Quote:
Originally Posted by My Wife
I might just go crazy and kill you in your sleep, instead of just planning it.
venom is offline  
Sponsored Links
Advertisement
 
post #2 of 28 Old 12-05-2008, 09:31 PM
JKO Addict!
 
bodyguy's Avatar
 
Join Date: Jul 2008
Location: Shit Creek, Texas
Age: 42
Posts: 4,013
Feedback: 0 reviews

Strange

Has anyone had their jeep not turn off until you reinsert the key and turn it on and off again. happened to me once


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bodyguy is offline  
post #3 of 28 Old 12-05-2008, 09:33 PM
Super Moderator
 
StubEXrube's Avatar
 
Join Date: Jun 2008
Location: Austin Texas
Posts: 15,341
Garage
Feedback: 5 reviews

Quote:
Originally Posted by venom View Post
Hope this isnt a sign of things to come......
x2. Seems that whenever somebody thinks all is well with the JK, that out of nowhere, comes something new and unexplained. There was a TSB that I was reading about recently that seemed "connected" to cold/ dry weather. Don't remember if it was an electrical or G40 tsb- but I know it's been pretty cold and dry up there the past couple days.

Hope (like the elec glitches I've had) that it goes away...permanently.
StubEXrube is offline  
Sponsored Links
Advertisement
 
post #4 of 28 Old 12-05-2008, 09:48 PM
Super Moderator
 
StubEXrube's Avatar
 
Join Date: Jun 2008
Location: Austin Texas
Posts: 15,341
Garage
Feedback: 5 reviews

Not sure if this could be related venom.

This TSB (#08-007-08)
affects some 07-08 JK's
built on or before Nov- 30th- 2007

*No engine crank/ start due to lock-up of WCM/ SCREEM

...Remote keyless entry may not operate....Condition may occur more frequently in cold/ dry weather due to electrostatic discharge/ ESD...Replace WCM (wireless control module).


Doesn't say anything about affecting the radio...so not really sure if this is relevant. Maybe. (?)
StubEXrube is offline  
post #5 of 28 Old 12-05-2008, 09:57 PM
Super Moderator
 
StubEXrube's Avatar
 
Join Date: Jun 2008
Location: Austin Texas
Posts: 15,341
Garage
Feedback: 5 reviews

Quote:
Originally Posted by bodyguy View Post
Strange

Has anyone had their jeep not turn off until you reinsert the key and turn it on and off again. happened to me once
Not seen that one yet. The glitch I've had is when turning the key off (still in ignition)...the alarm sounds (...horn starts honking repeatedly- like an alarm mode). The only way to stop it has been to hit "PANIC" on the the key. Seems to be totally random- and have not had it do it in a while.

I guess you can check possible codes by turning key on/ off three times without starting. Not sure if this is accurate or not.

New JK abbreviation should be JAMOT...(Just a matter of time ).
StubEXrube is offline  
post #6 of 28 Old 12-05-2008, 10:30 PM
JKowners Vendor
 
a plumber's Avatar
 
Join Date: Oct 2007
Location: Colorado
Posts: 2,531
Feedback: 3 reviews

Quote:
Originally Posted by StubEXrube View Post
Not seen that one yet. The glitch I've had is when turning the key off (still in ignition)...the alarm sounds (...horn starts honking repeatedly- like an alarm mode). The only way to stop it has been to hit "PANIC" on the the key. Seems to be totally random- and have not had it do it in a while.

I guess you can check possible codes by turning key on/ off three times without starting. Not sure if this is accurate or not.

New JK abbreviation should be JAMOT...(Just a matter of time ).
Quit sitting on your spare key!!!



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"The best beer cooler in the world will always be the edge of your favorite river."
a plumber is offline  
post #7 of 28 Old 12-06-2008, 08:39 AM
Super Moderator
 
StubEXrube's Avatar
 
Join Date: Jun 2008
Location: Austin Texas
Posts: 15,341
Garage
Feedback: 5 reviews

Quote:
Originally Posted by a plumber View Post
Quit sitting on your spare key!!!
StubEXrube is offline  
post #8 of 28 Old 12-06-2008, 09:53 AM
Openly Hostile
 
Join Date: Apr 2008
Location: Mission Viejo, CA
Age: 41
Posts: 6,984
Feedback: 4 reviews

I had my TIPM go nuts on me and I couldn't turn the jeep off period. had to put it in 4th and drop the clutch to kill the engine every time! They ended up replacing the TIPM.

Jason
SDMF is offline  
post #9 of 28 Old 12-06-2008, 02:19 PM
Wheeler
 
Dave85Cj7's Avatar
 
Join Date: Dec 2008
Location: Brick, NJ
Age: 49
Posts: 19
Feedback: 0 reviews

Here is my possessed JK story. A few months back, I put my rear windows up at the same time and the radio cut off completely. No display what so ever, not even the clock. If that wasn't crazy enough a couple of weeks ago I went to go out, so I unlocked the door with the remote, as usual, started her up and the headlights where on, the ignition running, and the headlight switch was in the off position. Also the turn signals and the wipers weren't working. Both times I played with the fuses and banged my head against the wall a few times and everything straightened itself out and hasn't happened since.

Has anyone had that happen?

Last edited by Dave85Cj7; 12-06-2008 at 02:47 PM.
Dave85Cj7 is offline  
post #10 of 28 Old 12-06-2008, 05:16 PM
Super Moderator
 
StubEXrube's Avatar
 
Join Date: Jun 2008
Location: Austin Texas
Posts: 15,341
Garage
Feedback: 5 reviews

Jeep should have named the JK...

Christine
StubEXrube is offline  
post #11 of 28 Old 12-06-2008, 07:27 PM
Alec W
Guest
 
Posts: n/a

I’ve had a few different “Christine”events, once every dash light came on and I could take the key out and it stayed running with them on still. Had to disco the battery to clear it and it was fine after that. Something’s broken on mine permanently where I don’t have to put my foot on the brake to shift into gear, probably should take it in but…
post #12 of 28 Old 12-06-2008, 07:42 PM
JKO Addict!
 
bodyguy's Avatar
 
Join Date: Jul 2008
Location: Shit Creek, Texas
Age: 42
Posts: 4,013
Feedback: 0 reviews

Quote:
Originally Posted by Alec W View Post
I’ve had a few different “Christine”events, once every dash light came on and I could take the key out and it stayed running with them on still. Had to disco the battery to clear it and it was fine after that. Something’s broken on mine permanently where I don’t have to put my foot on the brake to shift into gear, probably should take it in but…
Mine is the same way


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bodyguy is offline  
post #13 of 28 Old 12-07-2008, 04:21 PM
Rock God
 
Join Date: Sep 2007
Location: Carrollton, TX
Age: 65
Posts: 573
Feedback: 0 reviews
Send a message via AIM to jocrazy0

I've had the radio and lights come on with unlock once. Had the horn honk with unlock once. Current (happens EVERY time I open the door), the radio attempts to eject a non-existent CD. Somewhere between 5 and 15 seconds after opening the door, the eject motor runs on the CD. EVERY FRIKIN TIME. No wonder the battery runs down after not using the jeep for a few days. There is so much phantom load from the various computers its amazing the thing doesn't lose its ever loving mind trying to talk to itself. (I have also had all the flashes done, the first one done because of the computer reset, engine die and restart while driving power symptom).

2007 Rubicon, Graystone, Auto, Dual, Power, Tow,GENTEX autodim mirror,COOL TECH antenna mount&exhaust,CIBIE,HELLA TPMS,AEM CAI, Fuel Door, Grab Handles,Tuffy,Thule,Olympic,HESCO Supercharger, HID, RR XHD FB w/stinger,DRAKE hoodlatch with locks
1972 C104 Commando - Bone stock
jocrazy0 is offline  
post #14 of 28 Old 12-08-2008, 06:00 AM
Granite Guru
 
Hilldweller's Avatar
 
Join Date: Sep 2008
Location: Hog Waller, GA
Age: 56
Posts: 229
Feedback: 0 reviews

Quote:
Originally Posted by StubEXrube View Post
Not seen that one yet. The glitch I've had is when turning the key off (still in ignition)...the alarm sounds (...horn starts honking repeatedly- like an alarm mode). The only way to stop it has been to hit "PANIC" on the the key.
I had this happen one time too.

Also had it lock the doors for no reason while I was getting gas.

And 3 times the Sirius refused to play until I shut the Jeep off and restarted. The display showed the Sirius station but there was no audio.

Safety fast,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Get to know
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Hilldweller is offline  
post #15 of 28 Old 12-08-2008, 06:04 AM
Rock God
 
kerryp's Avatar
 
Join Date: Apr 2008
Location: Bastrop, Texas
Age: 55
Posts: 1,852
Feedback: 1 reviews
Send a message via Yahoo to kerryp Send a message via Skype™ to kerryp

Quote:
Originally Posted by bodyguy View Post
Strange

Has anyone had their jeep not turn off until you reinsert the key and turn it on and off again. happened to me once
Walked out to come over to your house the other morning and hit the unlock button on the key and the horn went off. I'm sure my night shift police officer neighbor appreciated that.

I have unlocked a couple times and the lights didn't come on, the other day I shut if off and opened the door to get out and it started dinging at me like I had left the lights on, checked them and they were off, closed the door and re-opened and it stopped.......
kerryp is offline  
post #16 of 28 Old 12-30-2008, 01:38 PM
Newbie
 
Join Date: Dec 2008
Age: 55
Posts: 1
Feedback: 0 reviews

Quote:
Originally Posted by Hilldweller View Post
And 3 times the Sirius refused to play until I shut the Jeep off and restarted. The display showed the Sirius station but there was no audio.
I get that a lot. But all I need to do is change the channel and it comes back without a problem.
MojaveDesertJK is offline  
post #17 of 28 Old 01-04-2009, 08:37 PM
Newbie
 
Join Date: Nov 2007
Posts: 5
Feedback: 0 reviews

Sometimes my rear power windows won't work until I turn it off and restart it. Sometimes when I unlock the doors with the key fob, the head lights turn on, sometimes they don't. My left front speaker didn't work for a long time, and now it's fine. Minor things, I know, but later on in it's life it could become a real nightmare. That's why I've got my eyes open for an Unlimited TJ. More basic. When I find one, I'll trade mine in. I have an 07 Unlimited Rubi.
whtIwrk4 is offline  
post #18 of 28 Old 01-05-2009, 07:01 PM
Granite Guru
 
W3CSX's Avatar
 
Join Date: Oct 2007
Location: Maryland
Posts: 111
Feedback: 0 reviews

Quote:
Originally Posted by venom View Post
...While I was walking out to the Jeep, I hit unlock on the fob to trigger the headlights get some illumination.
When I got to it, the radio was playing.
when I opened the door it cut just like its supposed to do when you shut the Jeep off, how it keeps playing till you open the door.
Didn't do it again,just the one time.

Hope this isnt a sign of things to come......

I have had this happen twice now. First time about a year ago, then again back in September. Not sure if the radio came on when I unlocked it with the remote or not. Both times I hit the unlock before I was close enough to hear it playing. Made you go "What the..." both times.

‘07 steel blue two door Rubi.
-RE 4.5"; 35"; 4.88's; Protected by River Raiders, Skid Row, & Rock Hard skids; Custom on board air; Ham radios; other mods by Warn, Poly Performance; & a few other toys.
W3CSX is offline  
post #19 of 28 Old 01-06-2009, 05:49 AM
 
Join Date: Dec 2008
Posts: 18
Feedback: 0 reviews

the only troble i had out of mine was the MYGIG acting a dang fool. it one of three things. CD will start back at one when you start up, or it will take like 2 min for the radio to come on after you start the car, and or 3 the radio will come on but the volume button wont work and the radio is on but no sound. thats the only trouble i have had with mine. that and my mygig wont play dvds with my 6sp either. it will play the sound but no video. that with it in neutral running with the parking break on.
FirefighterEMT is offline  
post #20 of 28 Old 01-06-2009, 06:16 AM
Granite Guru
 
Join Date: Sep 2008
Location: Front Royal, VA
Age: 43
Posts: 242
Feedback: 1 reviews
Send a message via AIM to 08RubiUnlimited

Mine has twice now decided to unset my auto unlock feature for no reason...althoguht I was using the remote start more than normal when it happened, so now I'm wondering if it's tied to that...
08RubiUnlimited is offline  
post #21 of 28 Old 01-06-2009, 06:47 AM
JKO Addict!
 
RotorHead's Avatar
 
Join Date: Oct 2007
Location: Dacula, Georgia
Age: 52
Posts: 3,201
Garage
Feedback: 0 reviews

I have had the radio not turn off when my top and doors were off. I had to disconnect the battery to reset.

For you guys with the Mygig and Sirius Radio problems, I used to deal with this. It's an easy fix. You're not gonna believe me, but you will be happy if you try it. There are two fusses that control the system. One for the amp and one for the head unit. They are intertwined though, so if the amp doesn't cut on the head unit will act up and so forth. All you need to do is either replace these two fuses or work them in and out a few time to clean of the contacts. There's some sort of coating on them from the factory that makes the connection intermittent. I don't remember the fuse numbers, but they are labeled in the manual. Can't hurt to try, right? It worked for me. I used to have slow start issues, no audio or radio control, mygig reboots, cd start over. Not anymore.

As far as the dash lights lighting up like a christmas tree goes, this has usually been classified with the stall bug. It is basically the computer rebooting. You will notice the same sequence, when you start the Jeep. Mine has done this about 5 times in the almost two years since I've had it. My engine has never died like some have experienced though. I have never heard an official cause of the stall bug and always assumed it was a software bug, but the bad ground on the ECU theory makes since.

Other than that, nothing to report. I love my Jeep.
RotorHead is offline  
post #22 of 28 Old 01-06-2009, 07:17 AM
 
Join Date: Dec 2008
Posts: 18
Feedback: 0 reviews

ok sorta kinda hijacking the thread... when it comes to taking the doors off of my rubicon. i have the half doors so i have like two wires that run along the retention strap at the foot of the door. what do i need to do with those when its time to take the doors off completely? Cut them and put connectors on both ends so i can just diconect them or use a wire tie.
FirefighterEMT is offline  
post #23 of 28 Old 01-06-2009, 07:36 AM
JKO Addict!
 
RotorHead's Avatar
 
Join Date: Oct 2007
Location: Dacula, Georgia
Age: 52
Posts: 3,201
Garage
Feedback: 0 reviews

Quote:
Originally Posted by FirefighterEMT View Post
ok sorta kinda hijacking the thread... when it comes to taking the doors off of my rubicon. i have the half doors so i have like two wires that run along the retention strap at the foot of the door. what do i need to do with those when its time to take the doors off completely? Cut them and put connectors on both ends so i can just diconect them or use a wire tie.
There is already a quick disconnect there for you. You'll find it if you follow the wires to the kick panel. There is a red tab that must be slid out the first time. In locks it and out unlocks the quick disco. It doesn't slide all the way out, just a half inch or so. Then you have to mash really hard with your thumb on the center middle while sliding the disconnect apart. It's kind of hard the fist couple of times until you get the hang of it. The rears are the same way if you have a four door.
RotorHead is offline  
post #24 of 28 Old 01-06-2009, 07:40 AM
 
Join Date: Dec 2008
Posts: 18
Feedback: 0 reviews

awesome thanks... yeah i do have the 4 door. where are the ones on the back doors located? do i need to pull any fuses either? or do they have that little thing you can buy like with the tjs that will keep the lights off inside so you don't have to pull fuses?
FirefighterEMT is offline  
post #25 of 28 Old 01-06-2009, 08:13 AM
JKO Addict!
 
RotorHead's Avatar
 
Join Date: Oct 2007
Location: Dacula, Georgia
Age: 52
Posts: 3,201
Garage
Feedback: 0 reviews

Quote:
Originally Posted by FirefighterEMT View Post
awesome thanks... yeah i do have the 4 door. where are the ones on the back doors located? do i need to pull any fuses either? or do they have that little thing you can buy like with the tjs that will keep the lights off inside so you don't have to pull fuses?
They are inside the removable panel on the b pillar. No need to remove fuses.
RotorHead is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome