Headlight/horn malfunction - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-20-2019, 03:22 PM Thread Starter
Newbie
 
Join Date: May 2019
Posts: 1
Feedback: 0 reviews
Headlight/horn malfunction

I've seen a few threads tangentially related to this, but cannot figure out the fix...
I have a 2013 JKU and I had an incident where the steering wheel controls stopped working (dry pavement, no rain), then the next time I unlocked it, with key or remote, the horn would sound for 30 seconds straight, no matter what I did, then quit, but not work an ANY OTHER TIME. Unhook the battery, discharge the residual charge (Pos to Neg >5min). hook battery back up, horn sound >30 secs. unlock or open the hood, horn sounds, etc.
Figured it was clockspring, have a recall notice, took to stealership. They said it was a "stuck horn switch". I replaced the switch-no diff myself, (Yes I know how to do it correctly). Took it back to the stealership who said they "replaced the clockspring", but I have the same result. 'Hooooooooooooooooooooooooonk" 30 secs. no workee otherwise...
QUESTION: Is there a relay somewhere that controls the horn? HELP (please). I NEED MY HORN!!!! (i'm a transplant in Alabama...)
I've seen a couple of pics online that seem to indicate there may be a relay in the TPMS that "may" be accessible?) ????

NEXT

The second issue (maybe related-maybe not)
Right fog quit working, figured it was a perfect opportunity to change heads and fogs to LED. Changed-got a cheap version of heads/fogs. right fog still doesn't work. swapped left/tight. right still doesn't work. Plus, the cheap LED Heads sucked. So bought better heads. they work great -WAY better than the cheapos, but now, my right DRL doesn't work- it worked, then quit working after a few cycles.
Question- can this be related to a CANBUS harness? Do I need to buy one of them? I've seen that maybe they increase the lower LED Bulbs resistance and that the LED's lower resistance can cause issues with the TPMS?

ANY advice would be appreciated. For the fogs, I have 12.4v at both OEM and pigtail harness, but RH fog doesn't work when I connect it....haven't checked the RH DRL for voltage.

Please help, and I apologize if this has been answered elsewhere-I just couldn't find it.
cardinexile is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn - delay when pressing horn button BigMike Electrical & Lighting Tech Dept. 9 09-09-2015 09:24 AM
Malfunction Indicator Light?!? serbNYC JK General Discussion 6 05-27-2014 03:25 PM
Idler Pulley Malfunction airmech777 Stock JK Tech Dept. 7 02-09-2012 07:15 PM
Electric windows malfunction vonhef JK General Discussion 5 01-03-2012 04:11 AM
Malfunction indicator light...HELP! ynkedad Modified JK Tech Dept. 8 09-10-2009 03:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome