Help identifying an issue - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-01-2018, 06:13 AM Thread Starter
Newbie
 
Join Date: Sep 2018
Location: Pittsburgh pa
Posts: 1
Feedback: 0 reviews
Help identifying an issue

I have a 2007 Sahara with 116k on the clocks, literally has been trouble free for 11years. Recently it developed what I though was a spark issue. So I replaced the plugs and one showed a crack so I thought sure this was the issue. Nope!
So I progressed to changing the wires and then the ignition coil. No change. I changed the PCV and cleaned the throttle body also in hopes this was the issue but Iíve seen no change.ive run sea foam through the block and in the fuel system also. Hereís the thing, it runs fine cold but as it heats up it develops what I thought was a misfire, only Iím not seeing a loss in rpm and no codes. There does seem to be a bit of a skip in the exhaust note and the engine does jump a bit. Can anyone think of other possible causes for these symptoms?
1rishmike is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-01-2018, 01:54 PM
Granite Guru
 
rockystock's Avatar
 
Join Date: May 2014
Location: Knoxville, TN
Posts: 365
Garage
Feedback: 0 reviews

Probably worth taking off your exhaust manifold heat shield and inspecting for manifold cracks. Mine had a crack and behaved well after replacing the manifold. Recommend starting with driver side; they seem to be a bit more prone to cracking first.
rockystock is offline  
post #3 of 3 Old 09-01-2018, 01:57 PM
Granite Guru
 
rockystock's Avatar
 
Join Date: May 2014
Location: Knoxville, TN
Posts: 365
Garage
Feedback: 0 reviews

Also recommend taking off the throttle body and cleaning. If you need RTV to re-seal the tb to the intake, make sure you give it plenty of time to fully cure. Ask my dumbass how I know lol.
Edit - nevermind should have read your whole thread sorry!

Last edited by rockystock; 09-01-2018 at 02:00 PM.
rockystock is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome