New purchase with a slow to crank issue - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-01-2017, 06:39 PM Thread Starter
Newbie
 
Join Date: Apr 2017
Posts: 1
Feedback: 0 reviews
New purchase with a slow to crank issue

I bought a used 07 X model 2 weeks ago and from the day I brought it home it has had a slow response time to crank once key is turned. Today for the first time it failed to ever turn over. I though battery but went to jump it and no change. Cleaned terminals and bamm it fired up. Killed it and then it failed to start again. Really uncomfortable to take it out now.
Any suggestions welcomed.
07 Wrangler 2 door X, STD Trans, Manual windows & locks............ every start has been turn key and wait a second or two for and reaction. Tried pushing the clutch up and down, moving gear shift around, switching key from off to on several times.
rayotten is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-01-2017, 07:24 PM
Granite Guru
 
Rb6700's Avatar
 
Join Date: Feb 2017
Posts: 265
Feedback: 0 reviews

Most likely a bad starter. There are test you can do to see for sure but most likely a starter.

Pissing off my wife since way back
Rb6700 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome