15k miles second engine down - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-06-2016, 12:04 PM Thread Starter
Newbie
 
Join Date: Dec 2013
Age: 45
Posts: 1
Feedback: 0 reviews
15k miles second engine down

At 7500 miles I lost my first engine. It kept dying and I kept starting it because no engine light and temp was fine. dum d dumm dumm, the darn thing was loosing oil pressure and I didn't find the readout till to late. While on a trail ride with 20 other jeeps and with 7500 on my second engine it started acting the same but I was ready for it. Once it died I checked the oil pressure and it was low, 8 psi, at idle. I have found that the 3.6 is ok with 5 psi smdh. Long story short, I changed the oil and filter with full syn and some lucas and was able to drive it 4 hrs to home. I will have to change a few tappets and while at it would like to add an oil cooler but havent found any on the market to bolt up to the crazy system they made.

Has anyone else had this issue with the 3.6? I think it has to do with the low psi these run at idle and the slow pace of crawling. I am currently waiting on Chrystler to contact me. Being that me engine is not under warrenty (long story that would piss off the pope) I am hoping they will want to know wth is going on too.. in the mean time I will take any advice you guys could give. 2015 JKU Rubi.
paducahshane is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-08-2016, 12:00 AM
Granite Guru
 
Tierhog's Avatar
 
Join Date: Jan 2016
Location: Modesto, Ca
Age: 47
Posts: 378
Garage
Feedback: 0 reviews

I have a 2015 JKUR. I have had zero issues with the 3.6. Snow, desert, high elevation, etc. Super smooth powerband, idles like a kitten. Probably one of the best engines I've ever had. Ive had 7.3PSD, 4.0,5.7...you name it. The pentastar is one slick motor. Oil change after break in is every 8k or whenever the oil life indicator goes off. Pennzoil platinum and a mopar filter.
Tierhog is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome