Jeep stuck in drive, shifter stuck in park - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-18-2016, 07:08 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Age: 43
Posts: 1
Feedback: 0 reviews
Jeep stuck in drive, shifter stuck in park

Need some help! I have been searching for the last couple of hours to solve this problem but dont seem to be having any luck. 2007 JK Sahara, 95,000 miles. I pulled into my garage today, put the jeep in park, engine still running, let my foot off the brake and it started to move forward. I braked and shut the engine off. The gear display under the speedometer shows its in D. Shift lever at first would freely move into all gears. Engine will not restart because trans is in D. I tried to use the manual shift lock override but for some reason it wouldnt work either. After much searching, i was thinking that some sort of linkage was broken at the shifter. I removed the console and the 2 pics below seem to show that the cable is still connected. The silver pin that drops down when you depress the shifter button will move downward like it is supposed to causing the cable to move as well. I did this with the key in the ignition in the on position. Depressing the button will not allow the silver pin to drop low enough for it to disengage from park. The only other thing i can think of at this point is that cable is disconnected at the transmission. I cant seem to trace it to the point underneath the jeep and see where it connects. If anyone has pics of that or can guide me as to where to look that would be helpful. I have also disconnected the battery just now to see if that possibly resets anything that could be causing the shift lock out. Any help is appreciated.
Attached Images
   
puckjer is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-19-2016, 05:29 AM
JKO Addict!
 
sixty5vdub's Avatar
 
Join Date: Oct 2009
Location: East of the Mighty Mississippi
Age: 49
Posts: 2,012
Feedback: 0 reviews

If I remember correctly on my '07, the shifter cable connected on the passenger side of the console, not the driver's side as shown in your pics. I think your pics are of the brake pedal shift lock assembly (the system that doesn't allow you to shift out of park without depressing the brake pedal). Take a look at the passenger side of the shifter assembly, and see if you can see something like this (not the best quality video, but gives you an idea of where to look and what the shifter linkage looks like):


Also, here is a video I found showing how to check / replace the bushing on the transmission side of the cable.

I would guess the cable popped off on the transmission side, maybe due to a bad bushing. Might be a good time to buy a new transmission shifter cable, since you are already half way there with having removed the console as much as you have.

AMP

'07 JKUR, Steel Blue, Spun Main Bearing Mod @ 46k miles
My new engine is a four letter word ..............
sixty5vdub is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome