brakes - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-13-2015, 06:16 PM Thread Starter
Newbie
 
Join Date: Oct 2015
Posts: 2
Feedback: 0 reviews
Angry brakes

I was in the bush on single track this past weekend. No harsh driving to speak of. I could hear my brakes squeak every time i backed up. on the way out i could smell the brakes and then the ABS light came on. The brakes were serviced less than 2 months ago. What could be the problem?
Billy G is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-13-2015, 07:16 PM
Rock God
 
BigTB's Avatar
 
Join Date: Mar 2014
Location: NW OH
Posts: 1,115
Feedback: 0 reviews

Were you driving with the parking brake applied?

You say the brakes where serviced recently, what was done?

Check the fluid level and for any signs of a leak.

Year, mileage?
BigTB is offline  
post #3 of 5 Old 10-13-2015, 07:22 PM Thread Starter
Newbie
 
Join Date: Oct 2015
Posts: 2
Feedback: 0 reviews

No the had brake was no on...kept feeling it because it felt like it was on. It's an 08 wrangler jk 2 door. And yes i see a slight wet area around the steel lines under
Billy G is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 10-13-2015, 07:36 PM
Rock God
 
BigTB's Avatar
 
Join Date: Mar 2014
Location: NW OH
Posts: 1,115
Feedback: 0 reviews

Definitely check the fluid level.

If you banged and crimped a brake line it could be leaking slightly and possibly holding a bit of pressure on the brake it feeds. Just an off the wall idea.

Hard to say for sure what the problem is over the internet.
BigTB is offline  
post #5 of 5 Old 10-15-2015, 04:09 AM
Granite Guru
 
Donut707's Avatar
 
Join Date: Mar 2014
Location: Norman Oklahoma
Age: 41
Posts: 177
Garage
Feedback: 0 reviews

You could have a stuck caliper or pad. if whoever serviced your brakes used a C-clamp to push the piston back inside the caliper they could have damaged it slightly . I have used a C-clamp and done that very thing, a seal started leaking and then the caliper froze (it was on a little Mitsubishi mighty max ) . i had similar symptoms with out the abs light. good luck
Donut707 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome