2007 JKU Clutch problems - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-21-2015, 01:28 PM Thread Starter
Newbie
 
Join Date: Sep 2015
Posts: 1
Feedback: 0 reviews
2007 JKU Clutch problems

I have a 2007 JKU 2wd 6 speed. This morning I jumped in it, started up just fine, pushed the clutch in and tried to put it in gear and it wasn't having it. I killed it, put it in gear then started it and it struggled. I couldn't let off the clutch once I had it in gear nor would it come out of gear. I have been told to check the fluid for it, but where do I find the reservoir for the clutch itself, aside from the brake fluid reservoir? If anyone can help or has an idea, i'm all ears.
HaydenFrederick is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-22-2015, 06:21 AM
Granite Guru
 
SGT. Jackalope's Avatar
 
Join Date: Dec 2011
Location: Livonia, MI
Posts: 134
Feedback: 0 reviews

Quote:
Originally Posted by HaydenFrederick View Post
I have a 2007 JKU 2wd 6 speed. This morning I jumped in it, started up just fine, pushed the clutch in and tried to put it in gear and it wasn't having it. I killed it, put it in gear then started it and it struggled. I couldn't let off the clutch once I had it in gear nor would it come out of gear. I have been told to check the fluid for it, but where do I find the reservoir for the clutch itself, aside from the brake fluid reservoir? If anyone can help or has an idea, i'm all ears.
the clutch shares the brake reservoir, there isn't a separate one for it. Is it just doing it in first? have you tried the other gears?

2007 rubicon unlimited
SGT. Jackalope is offline  
post #3 of 4 Old 09-22-2015, 07:49 AM
Granite Guru
 
FuLcRuM's Avatar
 
Join Date: Nov 2010
Location: Memphis, TN
Age: 43
Posts: 262
Feedback: 0 reviews

Has your throw out bearing been squealing? It may have failed.

My old 07 squealed like a bitch so I replaced the whole clutch and TB. Bearing was shot but the clutch was actually in really good shape. Not a fun job either, highly recommend doing it on a lift if you try it yourself.

Jeepless
FuLcRuM is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 09-22-2015, 02:07 PM
Granite Guru
 
JeepnPokey's Avatar
 
Join Date: Aug 2013
Location: Phoenix, AZ (Merica)
Posts: 399
Feedback: 0 reviews

I bet its your slave cylinder, if you havnt heard any noises like described above, more than likely not its your slave cylinder maybe.
My TB is shot and am putting a new clutch kit and slave cylinder in, sounded like a pissed off dying cat in my transmission....

OIF
JeepnPokey is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome