Temporary tight/stiff steering - sound familiar to anyone? - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-18-2015, 07:45 PM Thread Starter
Granite Guru
 
MrBreeze's Avatar
 
Join Date: Sep 2012
Location: Cave Creek, AZ to Fayetteville, AR, back to Scottsdale, AZ
Posts: 259
Feedback: 0 reviews
Temporary tight/stiff steering - sound familiar to anyone?

After a light day of wheeling, I had what felt like a binding/tight/stiff steering - not through out the entire lock-to-lock but in a couple spots/directions. Took significant force to turn the steering wheel in certain spots.

Did the standard check of fluid - no leaks, reservoir between min and max, no air bubbles, fluid flowing in properly. Put the front up on jack stands and rotated from lock to lock - there was no mechanical binding with tie rods, drag link, track bar, sector shaft/arm (I run a Synergy sector-shaft brace), no noise from the pump or steering box.

Here's the odd part - when the front was up, and rotating from lock to lock there was NO binding/tight/stiff feeling in the steering. Put it back down on the ground, and took it for a test drive. Problem gone.

Going to flush the PS fluid just in case there might have been something foreign in the fluid that affected the valving?

2012 JKU with 36K miles, running 35's

Anyone had this happen to them? Suggestions/ideas as to what it might be? Pump failing? Steering box/valve issues?
MrBreeze is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-18-2015, 10:05 PM
Wheeler
 
conejo's Avatar
 
Join Date: Jul 2014
Location: Phoenix, AZ
Posts: 76
Feedback: 0 reviews

The couple times I've had that symptom has turned out to be a bent steering stabilizer. If that was it though, you likely would have noticed it when you inspected the rest of the steering components.
conejo is offline  
post #3 of 3 Old 08-18-2015, 11:08 PM
Newbie
 
sef22's Avatar
 
Join Date: Mar 2014
Location: Bismarck, ND
Age: 31
Posts: 4
Feedback: 0 reviews

The exact same thing happened to me after 4 days of wheeling in colorado. I swapped out the PS pump and everything is working perfectly again.
sef22 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome