How much grease inside a Rubi sway bar disco? - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-13-2015, 11:26 AM Thread Starter
Granite Guru
 
Rossi46's Avatar
 
Join Date: Jun 2014
Location: Norcal / East Bay
Posts: 196
Feedback: 0 reviews
How much grease inside a Rubi sway bar disco?

I ended up getting a Rubicon sway bar double used. The guy who sold it to me had purchased it used and was keeping the motor as a back up for his Rubicon but no longer needs it or the sway bar. He tells me its a crap shoot if it works or not cause he has never tried. I tell him i'm going with the EVO no limits knob and it just so happens the guy who sold it to him gave him that as well as the motor. With the whole contingency is that it might not work but the price is worth it.

So I get the sway bar take off the motor put the EVO knob on and it works perfect! Try it 2nd time then 3rd and then nothing.... Its locked and wont disconnect. I take the whole thing apart to find out it looks like somebody packed grease in there with a spatula. The pics don't even do it justice as I had cleaned half that chit off already. See pictures below... So I clean it up and remove about 95% of the grease best I could put the whole thing back together and its working perfect again. My initial thoughts I'm thinking this one was packed so full of grease it wouldn't allow the fork or collar to shift back and allow it to disconnect.

My question is how much grease does this need to be packed if any at all? From the pictures I have found online (see last two pics) it looks like none.




Pics found online


Rossi46 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-14-2015, 06:37 AM
Granite Guru
 
SGT. Jackalope's Avatar
 
Join Date: Dec 2011
Location: Livonia, MI
Posts: 134
Feedback: 0 reviews

Mine had got stuck unlocked. I opened it up to find a small bit of rust on the fork and gear and no grease present at all. I cleaned up the rust and put a very light coating of belray water proof grease on it. It's been working great for the past few months.

I'd clean all the grease out of it and just apply a light coating of marine grease on the moving parts to keep it from rusting

2007 rubicon unlimited
SGT. Jackalope is offline  
post #3 of 6 Old 08-14-2015, 07:10 AM
Rock God
 
ronjenx's Avatar
 
Join Date: Aug 2010
Location: Maine
Posts: 1,876
Feedback: 0 reviews

The one in the "Study" thread was cleaned to show the internal parts.
The grease in your sway bar disconnect, as pictured, is about what it should have in it.

2008 Unlimited Rubicon Automatic
ronjenx is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 08-14-2015, 10:11 AM Thread Starter
Granite Guru
 
Rossi46's Avatar
 
Join Date: Jun 2014
Location: Norcal / East Bay
Posts: 196
Feedback: 0 reviews

Quote:
Originally Posted by ronjenx View Post
The one in the "Study" thread was cleaned to show the internal parts.
The grease in your sway bar disconnect, as pictured, is about what it should have in it.
Quote:
Originally Posted by SGT. Jackalope View Post
Mine had got stuck unlocked. I opened it up to find a small bit of rust on the fork and gear and no grease present at all. I cleaned up the rust and put a very light coating of belray water proof grease on it. It's been working great for the past few months.

I'd clean all the grease out of it and just apply a light coating of marine grease on the moving parts to keep it from rusting
Thank you to for the advice and thanks again ronjenx for doing that "Study" thread!
I'll replace some of the grease I took out before mounting it up tonight.
Rossi46 is offline  
post #5 of 6 Old 08-14-2015, 02:31 PM
Granite Guru
 
Join Date: Aug 2010
Location: Brisbane Australia
Age: 53
Posts: 359
Garage
Feedback: 0 reviews

While the EVO knob works well, I found you need to lube the thread or corrosion will seize it up. A daub of neverseize helps.
Rodjk is offline  
post #6 of 6 Old 08-15-2015, 04:46 PM
JKO Addict!
 
07unlimitedx's Avatar
 
Join Date: Dec 2008
Location: Calgary Alberta
Age: 49
Posts: 2,286
Garage
Feedback: 1 reviews

Lots of guys up here in Canuk land are having lots of problems with the Rubi sway locker. In Chrysler's wisdom they use steel and aluminum inside that design. Most have changed them out for something else. Where we wheel, lots of mud and water.

2014 JKU, Tera44, 4.56 gears, ARB lockers, RK 3.5" flex lift, ARB front & rear bumper, dual Viair 400C w/2 gallon tank, Zeon 10S, Nitto Tires, Genesis Dual battery kit, TeraFlex tie rod & flipped drag link, ARB Intensities and TeraFlex dual rate ST sway bar.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
07unlimitedx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome