Brake light on dash always on - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-05-2014, 11:36 AM Thread Starter
JKO Addict!
 
leman's Avatar
 
Join Date: Jan 2010
Location: Guntersville
Age: 28
Posts: 2,907
Garage
Feedback: 1 reviews
Brake light on dash always on

Brake light on the instrument cluster is always on in my jeep. Sometimes it shuts off at startup but will come back on with an audible ding within 5 seconds. Fluid is at correct level in the reservoir and hand brake lever is down. Awhile back too it to oreillys and their scanner picked it up saying low voltage in the system. They cleared it but the light is still on and they haven't picked it up again. Any ideas?

2008 steel blue sahara
with some doo-dads
leman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-05-2014, 11:57 AM
JKowners Vendor
 
MoTech's Avatar
 
Join Date: Apr 2011
Posts: 1,250
Feedback: 2 reviews

Quote:
Originally Posted by leman View Post
Brake light on the instrument cluster is always on in my jeep. Sometimes it shuts off at startup but will come back on with an audible ding within 5 seconds. Fluid is at correct level in the reservoir and hand brake lever is down. Awhile back too it to oreillys and their scanner picked it up saying low voltage in the system. They cleared it but the light is still on and they haven't picked it up again. Any ideas?
Make sure the 2 pin connector on the side of the brake fluid reservoir is plugged in.

MoTech
725-502-8507

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MoTech is offline  
post #3 of 4 Old 12-08-2014, 11:28 AM Thread Starter
JKO Addict!
 
leman's Avatar
 
Join Date: Jan 2010
Location: Guntersville
Age: 28
Posts: 2,907
Garage
Feedback: 1 reviews

it was plugged in, took it off and cleaned it just make sure and light is still on.

2008 steel blue sahara
with some doo-dads
leman is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 12-11-2014, 04:27 PM Thread Starter
JKO Addict!
 
leman's Avatar
 
Join Date: Jan 2010
Location: Guntersville
Age: 28
Posts: 2,907
Garage
Feedback: 1 reviews

after fiddling with it some more realized the wire lead into the plug was loose. Good to go now.

2008 steel blue sahara
with some doo-dads
leman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome