2007 3.8 knocking after switch to Mobile 1 - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 10-18-2014, 07:21 AM Thread Starter
Newbie
 
Join Date: May 2014
Location: Phoenix, AZ
Posts: 3
Feedback: 0 reviews
2007 3.8 knocking after switch to Mobile 1

I bought my Rubicon about 6 months ago been doing a bunch of work to it the oil looked clean so I waited 3000 miles, and changed it with some Mobile 1 I had 5-20 in it per what the oil fill cap says. When I was out wheeling last week we stopped at a BLM sign I got out to read it and left the engine running heard a rod knock. I only hear the knocking noise after it warms up so it could be piston slap which isn't always a big deal. I know that rod knocking was not there before. Maybe I should have left this engine on Dyno oil. Its got about 78k on it but it might be little high because the old owner didn't calibrate the speedo correctly and it is reading about 5 mph faster then you are really going I corrected it with the tuner he gave me. Maybe Ill try a heavier oil 5-20 seems light for Arizona heat.
kell490 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 10-18-2014, 09:07 AM
Granite Guru
 
Join Date: Jun 2013
Posts: 261
Feedback: 0 reviews

I think 5-20 is too light and you will find lots of information online about not using that weight in the 3.8 even though it's recommended. I run 10-30 In mine and it has stopped all of the cold start engine noise.

The 5-20 is recommended to get better MPG in the 3.8. Even though the block is a 25 year old design that was intended for 10-30. Lots of posts on this subject, go do some searching....
5.9lj is offline  
post #3 of 7 Old 10-18-2014, 02:50 PM
Rock God
 
Join Date: Nov 2010
Location: North AL
Age: 54
Posts: 661
Garage
Feedback: 0 reviews

I had the same problem in my 07. I switched to 5-30 and the knock pretty much went away. The engine also went from losing a quart every 1k to a quart every 2k.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Denny2565 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 10-18-2014, 03:06 PM
Rock God
 
LoneJK's Avatar
 
Join Date: Feb 2014
Location: Mt. Vernon Illinois
Age: 24
Posts: 592
Garage
Feedback: 0 reviews

mine had a rattle like a spray can, burnt 1.5quart 5W20 oil every 800-1k miles untill i switched to quakerstate 5w30 dino. no more oil burn(execpt like 1/4 quart at 2.6K miles)
my '07 Squirrel powered 3.8 loves the heavier lube

"Gremlin"
Nothing in my jeep is sacred, except my jelly beans and apple liquorice. Don't touch those...
LoneJK is offline  
post #5 of 7 Old 10-18-2014, 04:38 PM
Rock God
 
azoth99's Avatar
 
Join Date: May 2014
Location: Las Vegas
Age: 44
Posts: 575
Feedback: 0 reviews

had 50K in my old JK used penziol platunum and or Mobile 1 depending on what was available at the store 5W20 and never had issues.

Use Mobile 1 in my SRT8 and have never had issues with that either?


2014 JKU Rubicon, 2007 Superbee #692/1000, BMC Hooligan (my chopper yea it's a Rigid)
"There is no limit to the amount of good you can do if you don't care who gets the credit."
- Ronald Reagan 40th President of the United States (1981-1989)
azoth99 is offline  
post #6 of 7 Old 10-19-2014, 02:47 AM
Rock God
 
mrsig's Avatar
 
Join Date: Nov 2007
Location: Davie, Fl
Posts: 842
Feedback: 0 reviews

Been running the 5w30 for over 77,000 and no problems at all.

07 JKU, To see my mods & Jeep in Action @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

CEO of Black Sheep 4x4s
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Member of CCJ, White Jeep Club Member #137.
mrsig is offline  
post #7 of 7 Old 10-20-2014, 11:21 AM Thread Starter
Newbie
 
Join Date: May 2014
Location: Phoenix, AZ
Posts: 3
Feedback: 0 reviews

Ill try moving up to 10/30 a friend says he only uses 15/50 Mobile 1 I used to use that in older cars I had. I wonder how much of a difference it will be. I just wondered if there were any rod knock issues with these motors.
kell490 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome