Question for those with hemi's - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 01-20-2010, 05:42 PM Thread Starter
Rock God
 
JK Inferno's Avatar
 
Join Date: Jul 2009
Location: Phoenix
Age: 27
Posts: 582
Garage
Feedback: 0 reviews
Question for those with hemi's

For those lucky few of you running hemi's in your jeep, what kind of gears are you running in your axles? I've talked to people who have said that deeper gears (eg 5.13, 5.38) aren't good with a hemi. Just wanted to know what you guys have.

I understand the Jeep thing
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JK Inferno is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-20-2010, 08:41 PM Thread Starter
Rock God
 
JK Inferno's Avatar
 
Join Date: Jul 2009
Location: Phoenix
Age: 27
Posts: 582
Garage
Feedback: 0 reviews

no one?

I understand the Jeep thing
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JK Inferno is offline  
post #3 of 6 Old 01-20-2010, 08:56 PM
Wheeler
 
Join Date: Aug 2009
Location: Fort Worth, TX
Posts: 19
Feedback: 0 reviews

I am running 5.13s. Runs great. I have a 6.1 hemi!
almarti is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 01-20-2010, 10:04 PM Thread Starter
Rock God
 
JK Inferno's Avatar
 
Join Date: Jul 2009
Location: Phoenix
Age: 27
Posts: 582
Garage
Feedback: 0 reviews

Quote:
Originally Posted by almarti View Post
I am running 5.13s. Runs great. I have a 6.1 hemi!
Thanks for the answer, what kinda RPM's do you get at speed?

I understand the Jeep thing
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JK Inferno is offline  
post #5 of 6 Old 01-20-2010, 10:42 PM
JKO Addict!
 
RODICON's Avatar
 
Join Date: Oct 2008
Location: Gateway to the Sierra's
Posts: 5,678
Garage
Feedback: 3 reviews

I am running 5.13s with 37" tires and a 5.7 Hemi. I run 2000 rpm at 60mph with a545rfe auto trans.

2014 Rubicon on the build!
RODICON is offline  
post #6 of 6 Old 01-21-2010, 11:38 AM
Granite Guru
 
edivebuddy's Avatar
 
Join Date: Jan 2009
Location: Bartlett, IL
Posts: 295
Garage
Feedback: 0 reviews

5.7 33's 4.1 auto. 1800 @ 65. Mine will not shift into overdrive below 65
edivebuddy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome