Rear Wiper - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-13-2010, 09:47 AM Thread Starter
JKO Addict!
 
07unlimitedx's Avatar
 
Join Date: Dec 2008
Location: Calgary Alberta
Age: 49
Posts: 2,286
Garage
Feedback: 1 reviews
Rear Wiper

So I think my rear wiper is toast or may only be the switch. I have hooked up a 12 V source to the wiper itself, I get a little click sound and that's it. The switch won't work anything now, not even the washer pump. So is there any way to test the wiper motor, just to make sure that that is the problem?

Has anyone else had this same issue?

Thanks for the responses!

2014 JKU, Tera44, 4.56 gears, ARB lockers, RK 3.5" flex lift, ARB front & rear bumper, dual Viair 400C w/2 gallon tank, Zeon 10S, Nitto Tires, Genesis Dual battery kit, TeraFlex tie rod & flipped drag link, ARB Intensities and TeraFlex dual rate ST sway bar.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
07unlimitedx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome