Engine shut off during right hand turn - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 10-09-2013, 06:25 AM Thread Starter
Granite Guru
 
holy_crap's Avatar
 
Join Date: Aug 2010
Location: Weston, FL
Posts: 220
Feedback: 0 reviews
Engine shut off during right hand turn

The weirdest thing happened today on my way to work. I got off the interstate and on my first right hand turn the engine shut off . All electrical was still working, A/C on, lights on on the dash, but no RPM. I coasted to the side of the road, put it in neutral and started right up with no problems. I have between 3/4 and full tank of gas.

My Jeep is a 2010 automatic with 52000 miles. If it matters, I have a 3.5" lift with 35" tires, over a year with the current setup with no problems.

Anyone else experience this problem?
holy_crap is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 10-09-2013, 07:30 AM
Wheeler
 
Join Date: Feb 2013
Location: Knoxville
Age: 35
Posts: 73
Feedback: 1 reviews

Never experienced or heard of such a thing. Good luck.
Shammy O'Shea is offline  
post #3 of 12 Old 10-09-2013, 08:56 AM
Wheeler
 
TimeCloud's Avatar
 
Join Date: Apr 2012
Location: Roswell, GA
Posts: 22
Feedback: 0 reviews

Did you notice if the ESM light lit up as well. I had this happen a few times, but not recently.
TimeCloud is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 10-09-2013, 09:30 AM
Granite Guru
 
Join Date: Feb 2013
Location: Arizona
Posts: 267
Feedback: 0 reviews

A guy I work with used to be an auto mechanic for a Chevrolet dealer here in Arizona. Some guy reported the exact same thing as you, except it was an 80s Corvette. Turned out the fuel pump was defective in some way. Once it was replaced it never happened again.

I don't know if this applies in any way to your current problem though.

2005 Jeep Wrangler TJ Unlimited Rubicon
Demlockian is offline  
post #5 of 12 Old 10-09-2013, 09:39 AM
JKowners Vendor
 
MoTech's Avatar
 
Join Date: Apr 2011
Posts: 1,250
Feedback: 2 reviews

Codes?

MoTech
725-502-8507

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MoTech is offline  
post #6 of 12 Old 10-09-2013, 10:34 AM
Rock God
 
coilrod's Avatar
 
Join Date: Feb 2010
Location: Lower mainland
Age: 52
Posts: 1,620
Garage
Feedback: 0 reviews

This happened to my neice in a 2011 often enough that she traded it, and to me once. No codes for either of us. I have seen my fuel gauge drop to empty and my low fuel indicator go off also. Maybe I need a sending unit but it is not easy to test an intermittant issue. Could be a loose connector. Anyone out in the interwebs have ideas?
coilrod is offline  
post #7 of 12 Old 10-09-2013, 11:54 AM
Rock God
 
Join Date: Aug 2010
Location: Northern VA
Posts: 530
Feedback: 1 reviews

Is it a Rubicon and do you still have the factory electronic sway bar disconnect hooked up? When those go bad they can do some really funky things. I had my lights and dash die on me at night driving 80mph down a highway.

2011 JKU Rubicon
PSC Evap Skid
PSC Diff Covers
Dynomax Rock Crawler exhaust
ACE Rear Bumper and Tire Carrier
Rock Krawler 2.5 Flex W/ Bilstein 5100's
35" Nitto Trail Grappler's
G19T is offline  
post #8 of 12 Old 10-09-2013, 12:19 PM
Rock God
 
coilrod's Avatar
 
Join Date: Feb 2010
Location: Lower mainland
Age: 52
Posts: 1,620
Garage
Feedback: 0 reviews

My niece's was not. Mine is and the sway bar has since been procal'ed away
coilrod is offline  
post #9 of 12 Old 10-21-2013, 09:33 AM Thread Starter
Granite Guru
 
holy_crap's Avatar
 
Join Date: Aug 2010
Location: Weston, FL
Posts: 220
Feedback: 0 reviews

OP UPDATE: So far it's been a one time thing, let's hope it stays that way. No codes, not a Rubicon.

Thank you all for your input to the thread.
holy_crap is offline  
post #10 of 12 Old 10-21-2013, 08:39 PM
JKO Addict!
 
bnb2010's Avatar
 
Join Date: Nov 2010
Location: Plano, TX
Posts: 2,276
Feedback: 0 reviews

Could you have bumped your key? Might be worn enough to where it does not lock in the run position anymore.
bnb2010 is offline  
post #11 of 12 Old 10-21-2013, 09:45 PM
Rock God
 
DiscoBayJoe's Avatar
 
Join Date: Oct 2007
Location: Discovery Bay, CA
Age: 48
Posts: 990
Garage
Feedback: 1 reviews
Send a message via Yahoo to DiscoBayJoe

My jeeps is a manual, but i've noticed when coming off the freeway after a long run (100+ miles) it will quite often stall coming off the offramp at the first stop/light. It fires right up like it never happened. At first I thought I was just clutching poorly but eventually figured out it wasn't me. Seems like a computer glitch.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2008 JKUR 3.5" Frankenlift : RK/Artec/Synergy/Reid/Currie/PSC - Spyder'd Out - 35" MTR/K's on Spyderlocks - BinksFab Tailgate
DiscoBayJoe is offline  
post #12 of 12 Old 10-23-2013, 05:02 PM
Rock God
 
Chipewa's Avatar
 
Join Date: Jan 2012
Location: Farmington Hills MI
Posts: 1,184
Feedback: 0 reviews

Yeah, I used to have my JKU turn off unexpectedly and found it to be my heavy key ring that was turning the key off when I'd hit big bumps or the keys starting swinging around alot. I now off road with a single key in the ignition and have not had the problem since.

LS3 2007 JKU X - Red Rock, 2012 JKU Rubicon - Deep Cherry Red, 2001 TJ - Black
Chipewa is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome