Spal Fan Not Working Low Speed - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-20-2012, 06:43 AM Thread Starter
Rock God
 
Join Date: Apr 2009
Posts: 519
Feedback: 0 reviews
Spal Fan Not Working Low Speed

Ok guys does people using Spal fans can you please confirm if Spal runs on Low speed if yes what year is ur JK?

I am currently using Spal but for some reason the low speed is not working. Chcked the fuse and resistor pack all seems to be ok.

Does anybody has a detailed wiring diagram of stock fan with relays etc
JK07 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-20-2012, 06:46 AM
Rock God
 
NascarRubicon's Avatar
 
Join Date: Jun 2011
Location: New Castle De
Posts: 1,929
Garage
Feedback: 1 reviews

my low speed in my spal is equal to (in noise level) to high speed of my old stocker. when it goes into high speed (hot day a/c on max) i can hear it clear as day inside the convenient store

its really loud on high


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Eat Liquid Gold"
NascarRubicon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome