09 Sahara Speaker issue - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-28-2012, 02:39 PM Thread Starter
Newbie
 
Cobra2top's Avatar
 
Join Date: May 2012
Location: Voorhees, NJ
Posts: 3
Feedback: 0 reviews
09 Sahara Speaker issue

This past weekend here in South Jersey we got 5 inches of heavy rain. Next morning I head to my soft top JKU and the drivers floor is soaking wet. I can see a little water drops between the front and rear doors. Looks like this is where the rain came in and it makes sense as that is the direction the storm came from.

Dried it out and had no problems until last night (2 days later). My "left" side speakers started to crackle and then died. This morning they worked for about a minute when I turned the jeep on and then died. When I play with the balance, you have to turn the radio all the way up to get just a little sound out of the left speakers, so they are getting power. The right side speakers are fine with no issues.

Is there a way to fix this? Could water got behind the dash and shorted out my speakers? it's super annoying not having all 6 speakers working. The bass still works when I turn the balance to the left. Again, just the speakers on the left (drivers) side.

I have the stock Sahara system (no navi) if this helps.

Thanks!
Cobra2top is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-28-2012, 03:39 PM Thread Starter
Newbie
 
Cobra2top's Avatar
 
Join Date: May 2012
Location: Voorhees, NJ
Posts: 3
Feedback: 0 reviews

Well, I may have spoke too soon. After writing this post I went out and started up the Jeep. The left side was still not working. I started to feel around under the dash and found a panel under the steering wheel. I pulled that off and a plug with wires was sitting on a metal bar behind the panel. As soon as I touched the plug the speakers started to work. Literally just moved it a round and it worked.

Now my issue is I had the Jeep dealer add bluetooth to the Jeep when i boight it this year. They put in a Parrot system. Was not happy with it as i thought they would add a Chrysler unit to work off the phone button on the factory radio. Since it routs to the radio, it looks like the dealer used the plug to access the radio/speakers. I find it hard to believe Jeep would have just laid the wires the way it was siting then I found them.

At this point it is working for now. I will have to see how the wiring was suppose to be placed and secure it.
Cobra2top is offline  
post #3 of 3 Old 08-28-2012, 03:43 PM
JKO Addict!
 
Fklein6768's Avatar
 
Join Date: Jul 2009
Location: Central New Jersey
Age: 51
Posts: 4,835
Feedback: 6 reviews

You should not use the words jeep and dealer in the same sentence unless your getting a new jeep or warranty work done

Is this thing on?

www.4x4s-pod.com
Fklein6768 is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome