Did I purchase a bum radio? - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-15-2012, 05:17 PM Thread Starter
Wheeler
 
rustedxj's Avatar
 
Join Date: Jun 2012
Location: Johnston, RI
Posts: 58
Feedback: 0 reviews
Did I purchase a bum radio?

I recently bought a REN out of a 08 Nitro on ebay. Hooked it up and worked great. Called sirius and activated the radio. It worked fantastic for 3 days. Now it says "no signal" and cuts in and out. But when it goes in it only lasts for a second. Called sirius and they have no clue what it is.

Any advice?


Also does anyone know where to get software updates for the REN? Im 4 versions out but the mofv.com/mygig site is down.



Thanks,

Chris

-Chris
2007 JKU: Sprintex S/C'd, 35's, 2.5RC BB
rustedxj is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-15-2012, 06:15 PM
JKO Addict!
 
paramaniac's Avatar
 
Join Date: Jul 2009
Location: Philly, PA
Age: 45
Posts: 5,049
Garage
Feedback: 2 reviews
Send a message via AIM to paramaniac

Check that the antenna is in an "open" spot, meaning there isn't anything laying on top of. Also check that the antenna wire is actually plugged all the way in.

I used an aftermarket Sirius radio that I mounted on my dash. Occasionally the antenna wire would come loose from the head unit.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
paramaniac is offline  
post #3 of 7 Old 07-15-2012, 06:26 PM
Wheeler
 
Inkslinger's Avatar
 
Join Date: Mar 2012
Location: PA.
Posts: 37
Feedback: 0 reviews

Do you drive on a lot of tree lined roads? Mine works great in the winter.
Inkslinger is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 07-15-2012, 06:55 PM Thread Starter
Wheeler
 
rustedxj's Avatar
 
Join Date: Jun 2012
Location: Johnston, RI
Posts: 58
Feedback: 0 reviews

The antenna is plugged all the way in. It worked awesome(and I mean awesome for sirius didnt cut out once). Then all of a sudden today...nothing.

Sirius tried to resend the signal and master reset the account.

I really hope its not the radio because if it is I just got boned for 350.

-Chris
2007 JKU: Sprintex S/C'd, 35's, 2.5RC BB
rustedxj is offline  
post #5 of 7 Old 07-16-2012, 10:14 AM Thread Starter
Wheeler
 
rustedxj's Avatar
 
Join Date: Jun 2012
Location: Johnston, RI
Posts: 58
Feedback: 0 reviews

BUMP

-Chris
2007 JKU: Sprintex S/C'd, 35's, 2.5RC BB
rustedxj is offline  
post #6 of 7 Old 07-16-2012, 11:40 AM
Rock God
 
block's Avatar
 
Join Date: Sep 2009
Location: maryland
Posts: 1,612
Feedback: 4 reviews

i also would say antenna.. .maybe try a different one.. ive had one go bad before..
block is offline  
post #7 of 7 Old 07-16-2012, 02:31 PM Thread Starter
Wheeler
 
rustedxj's Avatar
 
Join Date: Jun 2012
Location: Johnston, RI
Posts: 58
Feedback: 0 reviews

I could try another antenna...but that would be the second new one in 2 days lol. Im going to go broke trying to pay too much for radio.

-Chris
2007 JKU: Sprintex S/C'd, 35's, 2.5RC BB
rustedxj is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome