Battery question - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 07-06-2012, 11:56 AM Thread Starter
Granite Guru
 
lineman's Avatar
 
Join Date: Oct 2010
Location: Birdsboro Pa
Age: 47
Posts: 137
Feedback: 1 reviews
Battery question

I just installed a brand new battery, and started the jeep up I shut her back down to clean up and now
she will not start. I get absolutely nothing no dash lights no sound. Someone please help me.

BUY AMERICAN MADE STUFF THE JOB YOU SAVE MIGHT BE YOUR OWN
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



AEV 4.5 Lift , Black Rock rims with 35''Goodyear MT/R , Viair compressor , 2 ARB's , 5.13 gears and RCV front axle.
lineman is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-06-2012, 11:58 AM
JKO Addict!
 
Goodysgotacuda's Avatar
 
Join Date: May 2009
Location: Denton, TX
Posts: 13,230
Feedback: 1 reviews

Tighten/check the battery cables.

SOLD - '09 2dr Rubicon - 1.0Gal | 6spd | 37s | 4.88s |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| OR-Fab cage | Poly Cage | BFH Front | XRC Rear | XRC12 Winch | Walker Evans Beadlocks |

Retired from the Jeep community, for now.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Goodysgotacuda is offline  
post #3 of 9 Old 07-06-2012, 12:41 PM
Banned
 
Join Date: Mar 2009
Location: Locked in a basement
Posts: 16,621
Feedback: 0 reviews

Start with the positive terminal.



Dancin Dan is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 07-06-2012, 12:43 PM
JKO Addict!
 
Goodysgotacuda's Avatar
 
Join Date: May 2009
Location: Denton, TX
Posts: 13,230
Feedback: 1 reviews

Quote:
Originally Posted by Dancin Dan View Post
Start with the positive terminal.
I'd say he has a 50/50 shot on which one it is

SOLD - '09 2dr Rubicon - 1.0Gal | 6spd | 37s | 4.88s |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| OR-Fab cage | Poly Cage | BFH Front | XRC Rear | XRC12 Winch | Walker Evans Beadlocks |

Retired from the Jeep community, for now.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Goodysgotacuda is offline  
post #5 of 9 Old 07-06-2012, 12:55 PM Thread Starter
Granite Guru
 
lineman's Avatar
 
Join Date: Oct 2010
Location: Birdsboro Pa
Age: 47
Posts: 137
Feedback: 1 reviews

I just checked both terminals in everything seems to be tight. I just checked the positive and negative lines and everything is tight there also. I check the starter fuse and that was good. anything else out there that can help me ?

BUY AMERICAN MADE STUFF THE JOB YOU SAVE MIGHT BE YOUR OWN
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



AEV 4.5 Lift , Black Rock rims with 35''Goodyear MT/R , Viair compressor , 2 ARB's , 5.13 gears and RCV front axle.
lineman is offline  
post #6 of 9 Old 07-06-2012, 12:59 PM
Rock God
 
Join Date: Aug 2010
Location: Northern VA
Posts: 530
Feedback: 1 reviews

Quote:
Originally Posted by lineman View Post
I just checked both terminals in everything seems to be tight. I just checked the positive and negative lines and everything is tight there also. I check the starter fuse and that was good. anything else out there that can help me ?
Did you touch any ground straps?

2011 JKU Rubicon
PSC Evap Skid
PSC Diff Covers
Dynomax Rock Crawler exhaust
ACE Rear Bumper and Tire Carrier
Rock Krawler 2.5 Flex W/ Bilstein 5100's
35" Nitto Trail Grappler's
G19T is offline  
post #7 of 9 Old 07-06-2012, 01:00 PM
Rock God
 
block's Avatar
 
Join Date: Sep 2009
Location: maryland
Posts: 1,612
Feedback: 4 reviews

i would guess a fuse... maybe unhook the battery for a few minutes.. let the computer reset then hook it up and give it a try .. that is weird.. ya never know .. they do strange things sometimes.. computers sometimes are wacky.
block is offline  
post #8 of 9 Old 07-06-2012, 01:14 PM
Granite Guru
 
scorro's Avatar
 
Join Date: Feb 2011
Location: New Smyrna Beach, FL
Posts: 224
Feedback: 0 reviews

I would check the battery also. It is unlikely but not impossible that the battery has an issue.

2008 JKU Sahara, Auto, 513s, TeraFlex performance leveling kit, 33" BFG ATs,
LOD Stubby front bumper, OR-Fab rear sheetmetal bumper,
Rugged Ridge 8.5k winch w/synthetic rope.

The voices in my head aren't real, but sometimes they have good ideas!
scorro is offline  
post #9 of 9 Old 07-06-2012, 02:28 PM Thread Starter
Granite Guru
 
lineman's Avatar
 
Join Date: Oct 2010
Location: Birdsboro Pa
Age: 47
Posts: 137
Feedback: 1 reviews

thank you to all who responded,especially so quickly. when I was disconnecting the battery I found a crack on the mechanical connection to the post. thanks again to all who posted have a good weekend.

BUY AMERICAN MADE STUFF THE JOB YOU SAVE MIGHT BE YOUR OWN
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



AEV 4.5 Lift , Black Rock rims with 35''Goodyear MT/R , Viair compressor , 2 ARB's , 5.13 gears and RCV front axle.
lineman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome