ECU/ TCM issues - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 03-26-2011, 02:15 PM Thread Starter
Wheeler
 
Join Date: Mar 2011
Location: Durham, Ca
Posts: 29
Feedback: 0 reviews
ECU/ TCM issues

I bought a totalled jeep and have been rebuliding it. I'm almost done but I can't start it and getting funky display. The ECU came in a lip lock bag with writing saying it's for the 07'/3.8L/Auto. The issue is the dash display reads that all my gears are lite that I'm in every gear so the nutural switch I believe won't let you start it with the key. I can jump start it at the starter but I can get nothing more then a spit or sputter after I put a little starting fuild spray. I'm not 100% sure this is the ECU/TCM that came out of the jeep or another one. The mileage is close to what they said it had.
HELP please
catmandojeeper is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 03-26-2011, 02:46 PM
JKO Addict!
 
SONIC's Avatar
 
Join Date: Feb 2008
Location: Bell Buckle, TN
Posts: 3,730
Feedback: 1 reviews

Well is yours 07/auto?
You cannot start a JK without the correct transponder key, which may be part of your issue. Your ECM has to be flashed to your key or vice versa to start at all, starting fluid and a jump will never do it, the CANBUS system is too complex.

If you are reading in all gears at once, have you checked the connection fromt he ECM to transmission? It sounds like that may be an issue as well.

Yes, but there's just something about him. Something around the eyes, I don't know, reminds me of... me. No. I'm sure of it, I hate him.
-Doc Holiday
Why are you highlighting my sig? You Bastard!
SONIC is offline  
post #3 of 7 Old 03-26-2011, 03:01 PM Thread Starter
Wheeler
 
Join Date: Mar 2011
Location: Durham, Ca
Posts: 29
Feedback: 0 reviews

Quote:
Originally Posted by SONIC View Post
Well is yours 07/auto?
You cannot start a JK without the correct transponder key, which may be part of your issue. Your ECM has to be flashed to your key or vice versa to start at all, starting fluid and a jump will never do it, the CANBUS system is too complex.

If you are reading in all gears at once, have you checked the connection fromt he ECM to transmission? It sounds like that may be an issue as well.
Yes it's an 07'/auto. I should of said that this is a "X" model. My key is not chipped if that's what you mean. It doesn't look anything like my other 07" Sahra that is chipped. I wonder if that might be some of my problem if the ECM is set up for the chipped key.

I will reconnect the connection at the ECM and at the connection at the tranny. Thanks.
catmandojeeper is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 03-28-2011, 08:44 AM
JKO Addict!
 
SONIC's Avatar
 
Join Date: Feb 2008
Location: Bell Buckle, TN
Posts: 3,730
Feedback: 1 reviews

That wll definitely make a difference.
The JK will not start without a chipped key.

Yes, but there's just something about him. Something around the eyes, I don't know, reminds me of... me. No. I'm sure of it, I hate him.
-Doc Holiday
Why are you highlighting my sig? You Bastard!
SONIC is offline  
post #5 of 7 Old 03-28-2011, 06:31 PM Thread Starter
Wheeler
 
Join Date: Mar 2011
Location: Durham, Ca
Posts: 29
Feedback: 0 reviews

Quote:
Originally Posted by SONIC View Post
That wll definitely make a difference.
The JK will not start without a chipped key.
Yep! Just talked to a company that reflashes the ECU and my VIN # calls for a chipped key and I email a picture of my key..... It's chipped. Boy how these keys have changed from what I'm used to. Guess I'll be reflashing my ECU. Thanks. Still have issues with the tranny reading correct. Might be all in the ECM/TCM??
catmandojeeper is offline  
post #6 of 7 Old 01-08-2012, 12:17 AM
Wheeler
 
Join Date: Nov 2007
Posts: 18
Feedback: 0 reviews

I can help you out if you still need to get it running.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2007 JK Unlimited 6 speed supercharged
2011 JK Unlimited Auto Supercharged. looking to purchase. pm me

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
thundercat90096 is offline  
post #7 of 7 Old 03-21-2017, 02:34 PM
Wheeler
 
apjk's Avatar
 
Join Date: Dec 2014
Location: Charlotte, NC
Posts: 34
Feedback: 0 reviews

Were you ever able to figure it out? I'm having the same problems
apjk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome