Default Front turn signal connector part #? - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 02-25-2011, 03:20 PM Thread Starter
Wheeler
 
Join Date: Sep 2009
Location: Ontario, Canada.
Age: 35
Posts: 99
Feedback: 0 reviews
Default Front turn signal connector part #?

The front turn signal connector on my '09 Rubicon has corroded and failed. Not the bulb, but the connector on the wiring harness itself. To be more specific, the middle wire corroded and came off, so now I have no parking lamp feature. Does anyone know a part number for this? I am still under warranty, but to waste a day at the dealer for this is not something I want to do.

Menard666 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 02-25-2011, 05:23 PM
Granite Guru
 
MoridinTX's Avatar
 
Join Date: Mar 2010
Location: Bryan, TX
Age: 49
Posts: 345
Garage
Feedback: 1 reviews

Quote:
Originally Posted by Menard666 View Post
The front turn signal connector on my '09 Rubicon has corroded and failed. Not the bulb, but the connector on the wiring harness itself. To be more specific, the middle wire corroded and came off, so now I have no parking lamp feature. Does anyone know a part number for this? I am still under warranty, but to waste a day at the dealer for this is not something I want to do.

From what I could see in the parts manual, this is not available as an individual part, only as the whole wiring harness.

Easiest/cheapest would be to go to Auto Zone or similar and get the appropriate connector for the type of bulb (with pigtail), and splice that onto your harness.

09 BLACK Sahara 4 Door - Auto, G2 4.88s
TF 2.5" Coil Lift w/shocks, TF Frnt Adj Trac, TF FLCA, JKS Discos, JKS Rear Adj Trac, LOD Full Rear GEN2,
A.C.E. Rock Rails, Viper TB: Check the Garage for more.

Last edited by MoridinTX; 02-25-2011 at 05:25 PM.
MoridinTX is offline  
post #3 of 9 Old 02-25-2011, 06:13 PM Thread Starter
Wheeler
 
Join Date: Sep 2009
Location: Ontario, Canada.
Age: 35
Posts: 99
Feedback: 0 reviews

Quote:
Originally Posted by MoridinTX View Post
From what I could see in the parts manual, this is not available as an individual part, only as the whole wiring harness.

Easiest/cheapest would be to go to Auto Zone or similar and get the appropriate connector for the type of bulb (with pigtail), and splice that onto your harness.
Maybe I'll have to let the dealer fix it then. I like your idea of finding the appropriate connector, but the issue I see is that this is a three piece system. The bulb, the socket adapter deal the bulb plugs into, and then the wiring harness piece that is screwed up that plugs into the socket adapter. I can't just wire in a universal socket that fits the 3157 bulb because it has to twist lock back into the turn signal housing somehow....
Menard666 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 02-25-2011, 08:12 PM
JKO Addict!
 
Fklein6768's Avatar
 
Join Date: Jul 2009
Location: Central New Jersey
Age: 51
Posts: 4,828
Feedback: 6 reviews

I am on my phone but I have the Chrysler website for wire/connector repairs on my computer-broke my tb connector and ordered just that kit for$25 instead of the whole harness. Will try and find it and post up.

Found it-

http://dto.vftis.com/mopar/main.asp

Didn't check for this specific "part" but they have a ton of shit listed-

www.4x4s-pod.com

Last edited by Fklein6768; 02-26-2011 at 05:40 AM.
Fklein6768 is offline  
post #5 of 9 Old 02-26-2011, 06:30 AM Thread Starter
Wheeler
 
Join Date: Sep 2009
Location: Ontario, Canada.
Age: 35
Posts: 99
Feedback: 0 reviews

Quote:
Originally Posted by Fklein6768 View Post
I am on my phone but I have the Chrysler website for wire/connector repairs on my computer-broke my tb connector and ordered just that kit for$25 instead of the whole harness. Will try and find it and post up.

Found it-

http://dto.vftis.com/mopar/main.asp

Didn't check for this specific "part" but they have a ton of shit listed-
Thanks for the link. This is the kit I came up with, think it's the correct one?

Mopar Package #
68065016AA

LAMP-PARK/TURN-RIGHT FRONT (EXCEPT EXPORT) - BLACK (HEADLAMP) 3 WAY

CAV CIRCUIT FUNCTION

1 L160 20WT/TN RIGHT FRONT TURN SIGNAL CONTROL

2 - -

3 Z904 20BK GROUND
Menard666 is offline  
post #6 of 9 Old 02-26-2011, 07:03 AM
zjr
JKO Addict!
 
zjr's Avatar
 
Join Date: Jul 2009
Location: Inside my beard.
Posts: 3,692
Garage
Feedback: 1 reviews

Sorry man... I can't find them. I did completely remove them though. I'll let you know if I can find them when I put on my wheels.

01111001011011110111010100100000011011000110111101 11001101110100001000000111010001101000011001010010 000001100111011000010110110101100101

Quote:
Originally Posted by caligirl View Post
James just came a little early......
Quote:
Originally Posted by njjk08 View Post
...May 2011 bless everyone with pervert wheeling days...
zjr is offline  
post #7 of 9 Old 02-26-2011, 07:14 AM Thread Starter
Wheeler
 
Join Date: Sep 2009
Location: Ontario, Canada.
Age: 35
Posts: 99
Feedback: 0 reviews

Quote:
Originally Posted by zjr View Post
Sorry man... I can't find them. I did completely remove them though. I'll let you know if I can find them when I put on my wheels.
No problem. I might go check out the delco part number you gave me, as it looks like they sealed the wires on that one. The Jeep connector really is a poor design, and I'm sure submerging my connections in water crossings hasn't helped
Menard666 is offline  
post #8 of 9 Old 11-07-2016, 10:30 PM
Granite Guru
 
1alembic's Avatar
 
Join Date: May 2013
Location: Central Florida
Posts: 268
Garage
Feedback: 0 reviews

I know this is a old thread but can anyone verify that the part number listed above works for a 2013 JKU?
Thanks.

2012 JK 2 door
37" MTRs
17" Rugged Ridge XHD wheels
Fold down "Jeep" tailgate
Sport roll bar
River Raider front and rear bumpers
Cut Rock Rails
AVE hood
Custom High Clearance fenders
Line-X'ed


Squatch build:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1alembic is offline  
post #9 of 9 Old 01-02-2019, 08:58 PM
Newbie
 
Join Date: Jan 2019
Posts: 1
Feedback: 0 reviews

Quote:
Originally Posted by Menard666 View Post
The front turn signal connector on my '09 Rubicon has corroded and failed. Not the bulb, but the connector on the wiring harness itself. To be more specific, the middle wire corroded and came off, so now I have no parking lamp feature. Does anyone know a part number for this? I am still under warranty, but to waste a day at the dealer for this is not something I want to do.



There is a pigtail connector u can get at the dealer that replaces this. The mopar part number is “6808 5016 AB”
A.j. Hamann is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome