2018 radio swap nightmare - JKowners.com : Jeep Wrangler JK Forum
 1Likes
  • 1 Post By GC_JK_62
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 01-29-2020, 04:42 PM Thread Starter
Newbie
 
Join Date: Jan 2020
Location: Ocean Springs, MS
Posts: 4
Feedback: 0 reviews
2018 radio swap nightmare

Hope we have some audio gurus on watch. I shot myself in the foot, I ordered my 2018 Sahara and followed some online advice regarding the audio system. The advise was: order the 9 speaker Alpine system, but, just get the base head head unit due to the high price of the Alpine. Then, find a plug and play aftermarket for a lot less $$. I bought a Pioneer AVH-4200NEX and had a local, reputable audio shop perform the swap. Of course, it involved the various adapters and the real McCoy Mopar harness for the steering wheel controls. The audio will play just fine for seconds, minutes or hours, and, suddenly, the left side of the speaker system will shut off. Then, it will come back on for seconds, minutes or hours and then, drop off again. The audio shop replaced the harness with an "updated" Mopar edition. Same result. The dealership (yes, it's still under warranty) has "washed it's hands" of the issue because original factory equipment has been replaced. The audio shop is at a loss, the dealership won't help, and here I am with a shot foot. Any suggestions?
GC_JK_62 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-29-2020, 07:03 PM
RMY
Wheeler
 
RMY's Avatar
 
Join Date: Oct 2018
Posts: 25
Garage
Feedback: 0 reviews

Hi recently put in an Alpine ILX-107 in my 2016 JKU. Got all the adapters from Crutchfield. Fairly simple install. So the shop that did you install basically not standing behind their work? Have you tried reinstalling the factory head unit to see if the problem persists? Bad head unit?


Sent from my iPhone using Tapatalk Pro

2016 JKU Rubicon
Teraflex ST3, BFG AT KO2 35x12.5R17
Alpine ILX-107
RMY is offline  
post #3 of 8 Old 01-31-2020, 03:51 PM Thread Starter
Newbie
 
Join Date: Jan 2020
Location: Ocean Springs, MS
Posts: 4
Feedback: 0 reviews

The audio shop has been really concerned and has taken my Jeep back 4 times to diagnose. They even paid for the updated wiring harness. The dealership has been less than helpful. Yes, re-installing the base unit is in the near future. The issue has gotten worse, the sound will cut off completly at times.
GC_JK_62 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 02-05-2020, 06:14 AM
Newbie
 
Join Date: Oct 2019
Posts: 3
Feedback: 0 reviews

Maybe overheating after time and the head unit is shutting down part of its amplifier circuit? I had a plastic inline fuse housing in my last vehicle that the housing cracked and would randomly make or not make the connection to power my external amp. Took quite a bit of troubleshooting to find that one, too. Another time, I had an RCA connector connection be bad, causing only partial signal strength getting to the sub amp, so the volume at times would be maybe 25% of what it should have been. In custom audio there can be all types of gremlins. Almost need to trace each individual wire, wiggle on them to confirm the sound doesn't drop out due to a certain angle/position of the wire and move onto the next.
PrimeTimeRubicon is offline  
post #5 of 8 Old 02-05-2020, 04:38 PM Thread Starter
Newbie
 
Join Date: Jan 2020
Location: Ocean Springs, MS
Posts: 4
Feedback: 0 reviews

Swapped out the Pioneer with the base unit. Problem solved. Too bad the Pioneer is out of warranty. Currently pondering my options.
GC_JK_62 is offline  
post #6 of 8 Old 02-07-2020, 08:12 PM
RMY
Wheeler
 
RMY's Avatar
 
Join Date: Oct 2018
Posts: 25
Garage
Feedback: 0 reviews

Hi ow is the pioneer out of warranty? Over a year old before installing? Used via eBay?


Sent from my iPhone using Tapatalk Pro

2016 JKU Rubicon
Teraflex ST3, BFG AT KO2 35x12.5R17
Alpine ILX-107
RMY is offline  
post #7 of 8 Old 02-08-2020, 12:34 PM Thread Starter
Newbie
 
Join Date: Jan 2020
Location: Ocean Springs, MS
Posts: 4
Feedback: 0 reviews

Purchased in late November 2018 (Black Friday sale) from Best Buy. Here's where the audio shop stumbled. They said Mopar had not released the "tech data" necessary to buy the correct wiring harness for the install. I waited on them for several months before pressing the issue. Turns out, the "tech data" wasn't really needed at all. The next few months was back and forth with the audio shop, trying to diagnose and fix the issue. Time flies when you don't think your brand new head unit is the issue. I don't drive the JK everyday, but, when the primary vehicle went in the shop for a week, the issue drove me nuts and into action. After doing a little research, I had an Alpine ILX-207 installed. I'm still learning how to use it, but, seems like a solid choice so far. Yes, I used a different audio shop.
RMY likes this.
GC_JK_62 is offline  
post #8 of 8 Old 02-08-2020, 03:35 PM
RMY
Wheeler
 
RMY's Avatar
 
Join Date: Oct 2018
Posts: 25
Garage
Feedback: 0 reviews

Interestingly the only difference between the ILX107 (discontinued) and the new ILX207 is they DROPPED wireless CarPlay. Canít understand why.


Sent from my iPhone using Tapatalk Pro

2016 JKU Rubicon
Teraflex ST3, BFG AT KO2 35x12.5R17
Alpine ILX-107
RMY is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome