GPS Antenna Error - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-08-2019, 03:07 PM Thread Starter
Newbie
 
Join Date: Nov 2019
Location: Lincoln, NE
Age: 55
Posts: 1
Feedback: 0 reviews
GPS Antenna Error

I'm replacing the 430N RHB radio in my 2014 JK 2 door Rubicon with a Pioneer AVIC W8400NEX, when I turn on the radio, go to the navigation screen I get a gps antenna error message that says to go see the dealer. If I leave the radio on and unplug the gps antenna and plug it back in, it seems to work, but when I turn the Jeep off and back on, I get the same antenna error message. I'm using the oem factory gps antenna with an idatalink Maestro NAV2 adapter. Any idea what's going on? Should I remove the factory gps antenna and use an aftermarket? Which aftermarket antenna would be good?

Thanks.
johnfinnell is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome