The Dreaded ESC light, need some help - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-17-2019, 10:32 AM Thread Starter
Granite Guru
 
Texas_Jester's Avatar
 
Join Date: May 2017
Location: Texas
Age: 55
Posts: 188
Garage
Feedback: 0 reviews
The Dreaded ESC light, need some help

Hi all,

I have searched all over the forum and I'm not quite finding anything that addresses my issue.

I have an ESC light coming on (2017 JKU), odd thing is it only seems to come on at slow speed turning out of a parking space or backing out of a parking space. I can clear it and it will go away for about 2-3 days, drives fine, then comes back on again coming out of a parking spot. It will sometimes clear itself on the next restart, but most of the time it does not.

I have been chasing this for a while and I'm not on a stock setup, 4.5" lift on 37's with a Pro-Rock 44 Unlimited front axle, PSC Hydro assist, Synergy Tie Rod and Tera Flex HD drag link, all the steering stuff is new this year, all joints (are now) new and in good shape, just had front end alignment re-checked last week, that's good, steering wheel is centered, axles are centered and vehicle tracks fine down the highway.

This started back in April, it seems, when I had a few hard knocks at Moab, I have since added the Hydro-Assist, New Tie Rod (it was starting to have that pretzel look) and New Drag link (rod ends were shot).

Additionally, I replaced the clockspring about a month ago thinking that was my issue but it has not fixed anything, light went out for about 3 days then back on again as explained above.

The two codes I keep getting when this happens are C1219 - Steering Angle Sensor Erratic Performance and C1240 Steering Angle Sensor Overtravel Performance. (this is from Superchips flashcal, so not sure how they correlate to any other device).

Any ideas where the heck my gremlin might be located or what I should check next to try and isolate the problem? It just aggravates me because I can't use my cruise control when the light is on and because I'm somewhat OCD and the light is not supposed to be on.......LOL.

Thanks in advance for any input.

Last edited by Texas_Jester; 09-17-2019 at 10:36 AM.
Texas_Jester is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-17-2019, 02:52 PM
Gunnery Sergeant USMC (ret)
 
Uncle Sams Misguided Child's Avatar
 
Join Date: Dec 2010
Location: Tucson AZ
Age: 52
Posts: 22,071
Feedback: 8 reviews

so it doesn't sound like a wheel speed sensor.

I did find this though. I don't know if it will work or not on a 2017.


Quote:
Originally Posted by lohchief View Post
If people don't take a stand now,you'll be bitches under their thumbs tomorrow.
Quote:
Originally Posted by StubEXrube View Post
I think too much of a pressure variant between Earth and outer-space... lack of oxygen... something like that.
Uncle Sams Misguided Child is offline  
post #3 of 3 Old 09-18-2019, 05:57 AM Thread Starter
Granite Guru
 
Texas_Jester's Avatar
 
Join Date: May 2017
Location: Texas
Age: 55
Posts: 188
Garage
Feedback: 0 reviews

I had tried this before with no success, but decided to try it again just to make sure. As before, this did not work, BUT, what it did do was kick the ESC light on (while sitting still) when turning the wheel to the left..................maybe I am getting closer to isolating something here. Its definitely not anything to do with the wheel speed sensor as the jeep was in park during this procedure. I may now be more confused than ever as I have the same number of steering wheel revolutions stop to stop in both direction

But this almost makes me think the thing might be out one full revolution somehow. I know when I put the Hydro in I secured the steering wheel at center and I know I centered the gear box before installing, so I'm really not quite seeing how it could be out that far if it is. I also had the steering wheel centered when I put in the new clockspring.

Dang new electronics are ridiculous.....LOL

Quote:
Originally Posted by Uncle Sams Misguided Child View Post
so it doesn't sound like a wheel speed sensor.

I did find this though. I don't know if it will work or not on a 2017.

https://www.youtube.com/watch?v=Xi9_29FFQVs
Texas_Jester is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome