New Battery, New Electrical Issues - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-11-2019, 06:02 PM Thread Starter
Newbie
 
Join Date: Sep 2019
Posts: 1
Feedback: 0 reviews
Question New Battery, New Electrical Issues

Hi. My wife bought a 2013 Wrangler Unlimited Sahara. She's the third owner of this vehicle. Battery died and I replaced it. Since then, when you turn the left turn signal on, the dome lights come on.

Has this happened to anyone else before?
Jamie Simmons is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-11-2019, 06:52 PM
Granite Guru
 
rockystock's Avatar
 
Join Date: May 2014
Location: Knoxville, TN
Posts: 478
Garage
Feedback: 0 reviews

Might have just bumped the TIPM while swapping the battery. Did you check the connectors?

Sent from my LG-H910 using Tapatalk
rockystock is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome