Fog lights quit working - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-05-2019, 04:23 PM Thread Starter
Newbie
 
Join Date: Jul 2018
Posts: 4
Feedback: 0 reviews
Fog lights quit working

I have a 2008 JK Unlimited. My fog lights have quit working. Has anyone else had this issue? The fog light indicator Also does not light up on the dash. Any thoughts on troubleshooting this issue.
Npkas44 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-06-2019, 08:39 AM
Wheeler
 
JeeperJoe's Avatar
 
Join Date: Dec 2016
Location: Jacksonville, FL
Posts: 32
Garage
Feedback: 0 reviews

Could be a couple different issues. I would start by checking your fuse. Since your fog light indicator isn't coming on it could also be the switch in the turn signal that either has a loose connection or has gone bad. I know this was an issue on the TJ's.

You can have a savings account or a Jeep.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JeeperJoe is offline  
post #3 of 6 Old 02-06-2019, 01:16 PM
Rock God
 
ronjenx's Avatar
 
Join Date: Aug 2010
Location: Maine
Posts: 1,872
Feedback: 0 reviews

Quote:
Originally Posted by JeeperJoe View Post
I would start by checking your fuse.
No fuse in the JK fog light circuit.

2008 Unlimited Rubicon Automatic
ronjenx is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 02-07-2019, 02:09 PM
Wheeler
 
JeeperJoe's Avatar
 
Join Date: Dec 2016
Location: Jacksonville, FL
Posts: 32
Garage
Feedback: 0 reviews

Quote:
Originally Posted by ronjenx View Post
No fuse in the JK fog light circuit.
Welp... guess you dont need to check the fuse...

You can have a savings account or a Jeep.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JeeperJoe is offline  
post #5 of 6 Old 02-07-2019, 07:57 PM
Granite Guru
 
rockystock's Avatar
 
Join Date: May 2014
Location: Knoxville, TN
Posts: 390
Garage
Feedback: 0 reviews

May want to check your connectors at the lights as well as the c300 connector (large connector near radiator on pass side). Check wiring down there, they usually get covered in dirt / grime. Next I'd recommend verifying all your TIPM connectors are pushed in firmly. After that, maybe check continuity / voltage on the switch. Could try disconnecting battery for a minute or so to jog the tipm.

Last edited by rockystock; 02-07-2019 at 08:46 PM.
rockystock is offline  
post #6 of 6 Old 02-09-2019, 08:16 PM Thread Starter
Newbie
 
Join Date: Jul 2018
Posts: 4
Feedback: 0 reviews

Thanks I’ll take a look at that
Npkas44 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Aftermarket Cruise Control Quit Working frogtn Electrical & Lighting Tech Dept. 0 01-16-2019 06:58 AM
Fog lights not working!? Rock lobster Electrical & Lighting Tech Dept. 9 01-09-2015 09:24 AM
Passenger side power window quit working xjtrailrider Electrical & Lighting Tech Dept. 7 07-13-2012 07:59 PM
Wiring fog lights to work with the low beams on a non fog light JK. gqjeep Electrical & Lighting Tech Dept. 2 05-18-2010 08:56 AM
am/fm quit working.. everything else fine Chrispy Stock JK Tech Dept. 3 03-01-2010 07:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome