Radio issues - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-27-2019, 09:09 PM Thread Starter
Newbie
 
Boostbyu06's Avatar
 
Join Date: Dec 2012
Posts: 3
Feedback: 0 reviews
Radio issues

I'm at a little bit of a loss, when I start my 13 jk up my factory radio works on FM for about 30 seconds and I get no sound of it. Bluetooth, and CD functions still have sound. I have checked the antenna for for any visible damage and checked to make sure connections are tight. Anybody have a similar situation or an idea of what's going on? Thanks for any help guys.
Boostbyu06 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-31-2019, 12:54 PM
Newbie
 
Join Date: Feb 2012
Location: El Cajon, CA
Posts: 1
Feedback: 0 reviews

Don't have an answer, but keeping an eye on any responses. My am radio volume fluctuates in and out...almost like being under a bridge. FM/CD/Bluetooth/Sat are all fine. I have pulled the radio out of the dash and checked the connections...all good on that end. I'm thinking something wrong with the am radio circuit. I have thought about replacing with a refurb to keep my steering wheel controls. Most aftermarket radios I have looked at want $100 extra for an adapter for the steering wheel.
bumbie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome