Please help!!! - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-16-2019, 05:15 PM Thread Starter
Newbie
 
Join Date: Sep 2016
Posts: 3
Feedback: 0 reviews
Please help!!!

I've searched and read numerous forums related to my issue, but it seems like nobody can pin point the exact problem. My jeep goes into limp mode quite often, and turning it off and back on will occasionally fix it. The etc and traction light comes on. It throws a lot of codes, cam position sensors, throttle pedal, low barometric pressure, erratic voltage, among many others. I've tried basics, took it to multiple local guys, all to no avail. All I can think is a possible bad ecm. I wanna avoid a dealership at all costs. Had anyone tried flagship 1 for an ecm. Seems like most people have had bad experiences. Anywhere else to get a reliable ecm? Or any suggestions as to a fix? By the way, it's a 2012 2 dr sport, 3.6 manual trans. Thanks for any help
Reaper90 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-16-2019, 07:39 PM
Rock God
 
Join Date: May 2010
Posts: 519
Feedback: 0 reviews

I had this exact problem about 1 year ago. One of my ECU lock levers was partially unlatched. Like, so little that I couldn't tell by looking at it. I unlocked both levers, looked at the pins and made sure everything was ok (no burns, corrosion, etc). Ratcheted the levers back down and never had the issue again.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

L/¯¯\\_ |"/¯¯¯(ºlllllllº)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

_(¯))==))..(¯))==))
marcspaz is offline  
post #3 of 4 Old 01-17-2019, 05:17 AM
Super Moderator
 
j3ff3ry_j33p's Avatar
 
Join Date: Jul 2012
Location: Nashville
Posts: 5,768
Garage
Feedback: 1 reviews

Quote:
Originally Posted by Reaper90 View Post
I've searched and read numerous forums related to my issue, but it seems like nobody can pin point the exact problem. My jeep goes into limp mode quite often, and turning it off and back on will occasionally fix it. The etc and traction light comes on. It throws a lot of codes, cam position sensors, throttle pedal, low barometric pressure, erratic voltage, among many others. I've tried basics, took it to multiple local guys, all to no avail. All I can think is a possible bad ecm. I wanna avoid a dealership at all costs. Had anyone tried flagship 1 for an ecm. Seems like most people have had bad experiences. Anywhere else to get a reliable ecm? Or any suggestions as to a fix? By the way, it's a 2012 2 dr sport, 3.6 manual trans. Thanks for any help



I would bet $20.00 that this is electrical. It is 9 times out of 10 an electrical issue on JKs.

Even tho you disagree, OP, check charge & all grounds to everything. It might be a bad TIPM but start w your grounds and battery charge first.
Your issues are too erroneous & "all over " & that "erratic voltage" PID error code is partially revealing....

Get your multimeter out & report back....



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
j3ff3ry_j33p is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 01-17-2019, 07:50 AM
Wheeler
 
bignblack's Avatar
 
Join Date: May 2018
Posts: 65
Feedback: 0 reviews

Quote:
Originally Posted by Reaper90 View Post
I've searched and read numerous forums related to my issue, but it seems like nobody can pin point the exact problem. My jeep goes into limp mode quite often, and turning it off and back on will occasionally fix it. The etc and traction light comes on. It throws a lot of codes, cam position sensors, throttle pedal, low barometric pressure, erratic voltage, among many others. I've tried basics, took it to multiple local guys, all to no avail. All I can think is a possible bad ecm. I wanna avoid a dealership at all costs. Had anyone tried flagship 1 for an ecm. Seems like most people have had bad experiences. Anywhere else to get a reliable ecm? Or any suggestions as to a fix? By the way, it's a 2012 2 dr sport, 3.6 manual trans. Thanks for any help

Whats your reason for not wanting to get it fixed at the dealer?
bignblack is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome