K10 relay blowing out m19 fuse - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-20-2018, 06:33 AM Thread Starter
Newbie
 
Join Date: Oct 2015
Age: 34
Posts: 2
Feedback: 0 reviews
K10 relay blowing out m19 fuse

Trying to get why relay k10 keeps blowing out m19 fuse I got a chance to start the jeep back up I was about to take it for a test drive but never got out of the driveway the just just shut off as soon as I pressed the gas pedal just trying to figure out what is connected to these 2 I'm seeing ignition coil,fuel pump, and 02 sensors but can't pin point what is causing the jeep to shut off I have a 2009 wrangler 3.8l
MIKE1108 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome