High Beams Won't Stay On - 07 Wrangler - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-21-2018, 02:25 PM Thread Starter
Newbie
 
Join Date: Apr 2018
Location: Comox, BC, Canada
Posts: 1
Feedback: 0 reviews
High Beams Won't Stay On - 07 Wrangler

We've got an 07 Wrangler that has us scratching our heads. Our high beams won't stay on. When you turn them on, they momentarily flash to on, and then go back to low beam. The indicator on the dash stays blue, like they are on. We've replaced the bulbs and also the multi-function switch. I'm hoping it's not the TIPM. There are no other weird electrical symptoms. Any ideas?
Wolperdinger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome