2017 Hardrock loses power - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-01-2018, 05:56 AM Thread Starter
Newbie
 
Join Date: Dec 2014
Posts: 2
Feedback: 0 reviews
2017 Hardrock loses power

Howdy,

I have a 2017 2dr Hardrock with the 6 speed (18,XXX miles). The weirdest thing has happened twice to it now. On both occasions I walk out to the Jeep, unlock the doors with the key remote. All is fine. I open the door, door lights and dash lights are all on like normal. I close the door, put the key in the ignition to try and start is and the Jeep looses all power. No dash lights, no interior lights, door locks don't work, key remote does not work. Nothing. Dead.

Both times I've sat there for about 2 minutes then all of a sudden the Jeep regains power and it will start and run like nothing happened. The clock and radio stations reset like the battery cables were disconnected.

The first time it happened I didn't think much of it because it ran fine. It didn't happen again until last night which was about 2 weeks since the first time it happened. The first time was in my driveway at home the last time was in the parking lot at a local resturaunt. I checked the battery cables and they are tight.

Has anybody else had this happen to them or heard of this happening?

Any help or insight is appreciated.

Thanks,
Larry
cj8larry is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome