2007 JKUR Rear lighting issue - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-07-2017, 07:15 AM Thread Starter
Wheeler
 
Rivesracing's Avatar
 
Join Date: Jul 2015
Age: 57
Posts: 14
Feedback: 0 reviews
Question 2007 JKUR Rear lighting issue

I have searched several threads that start with the title "Rear lighting issue" but none that ever actually found the solution. I noticed the battery dying twice in a two week period, not a DD, so it might sit a week or two between nice days. The right rear turn signal quits, check bulbs and swap to the other side all bulbs are good. blow it off as we are going on a 10 day trip off roading with it and T/S are overrated on the trail anyway. Day two on the trip lose left rear turn signal and come to find out the brake lights are not functioning either. Check all connections, clean everything up, remove the trailer harness from the equation, still only have running lights. Check continuity from module to each light, no problem there, when I did a voltage check, it read 10.9 on each circuit with everything OFF. Seems odd to me that there is voltage on the circuit with keys on the seat. anyone else have this issue and found a solution? Thoughts?
Rivesracing is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome