Help! Jeep won't start. - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-02-2017, 02:01 AM Thread Starter
Wheeler
 
Join Date: Sep 2016
Location: Mesa, AZ
Posts: 15
Feedback: 0 reviews
Help! Jeep won't start.

I have an 07 and I'm having an issue with my rig not starting. It started with the radio glitching off an on and the red security light would come on while it happened. Fast forward to Monday, I got to work turned it off, pulled the key and it was still running. I had to pull a fuse to shut it off. I put the fuse back in and the door chime went off and the lights on the dash turned on like the was a key in the ignition. I disconnected the battery and went into work. I got off work and reconnected the battery and the same thing happened. I got it towed home and my buddy and I looked it over and decided it was the ignition switch. So I got a replacement (just the switch not locking cylinder). We installed the new switch and it started, with some weird issues such as everything briefly coming on when I unlocked the doors with the fob. I went inside and came out the next morning, got in my Jeep and the aftermarket alarm light was flickering, I disconnected the battery and reconnected it with the key in the ignition and it started fine. Went to work and noticed the red light was on again. Got to work and went inside. I came out the next morning and the same thing, everything was on with no key in the ignition. My buddy and I messed around with it to no avail. He was about to tow me home when I decided to turn the key and it randomly started, with the red light on again. I drove home, turned it off and it was once again running with no key in the ignition. Removed a fuse to shut it off and and the same thing, door chime and all the lights on the dash came on like there was a key in the ignition and the aftermarket alarm light was blinking. After troubleshooting we decided that maybe the alarm failed. We removed it, reconnected the battery and everything came on again. I should also mention that when it thinks there's a key in the ignition it doesn't even click when I do put a key in and try to turn it on. My battery is brand new, the alternator and the starter are only a year old. Any advice?
Bvandam7 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-02-2017, 03:53 AM Thread Starter
Wheeler
 
Join Date: Sep 2016
Location: Mesa, AZ
Posts: 15
Feedback: 0 reviews

I should also mention that it's an automatic. Also, the key fobs do nothing at the moment. All the dashboard lights are on as well as the radio just like when there's a key in the ignition. I press the lock and unlock buttons and nothing happens.

I've tried disconnecting the negative cable to reset it and it still does the same thing.
Bvandam7 is offline  
post #3 of 4 Old 11-02-2017, 09:39 AM Thread Starter
Wheeler
 
Join Date: Sep 2016
Location: Mesa, AZ
Posts: 15
Feedback: 0 reviews

Anybody? I know there is a search function. I just don't know what to even search for.
Bvandam7 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 11-02-2017, 09:51 PM
Granite Guru
 
Rb6700's Avatar
 
Join Date: Feb 2017
Posts: 265
Feedback: 0 reviews

Sounds like a bad body control module.

Sent from my SM-N910V using Tapatalk
Rb6700 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome