Help, my dash is doing the funky chicken - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 10-04-2017, 09:54 PM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews
Help, my dash is doing the funky chicken

So all of a sudden while driving, my dash is going crazy. Traction control light, ESP light, sway bar light, oil pressure light, airbag light flash non stop and my tach needle bounces all over.

The jeep wouldn't start yesterday and my battery was reading very low so I swapped for a new one thinking that was the problem.

Its still doing the same thing. I pulled codes with my bullydog.

U0001 high speed can communication bus

U0141 lost communication with body control module

U1113
U110e
U110a
U1403
U110c

A week ago I attached a quick connect cable to the battery for my winch but havent gotten around to attaching the cables to the winch end so maybe moisture got into the quick connect end? That is not attached to the new battery at the moment.

Is my computer toast??

Any help would be appreciated...
I hope I don't get stranded on my way home from work lol.
BROWNING50CAL_M2 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 10-04-2017, 10:14 PM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews

After found some research online, I've seen a few people say that if there are any gaps in the battery terminals or if they aren't seated properly, this can be the problem and tightening can fix it.

It did start happening after I was messing with the terminals to add those quick connect wires for the winch. I'll go double check and see if thst makes a difference.
BROWNING50CAL_M2 is offline  
post #3 of 12 Old 10-04-2017, 11:07 PM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews

So after tightening everything connected to the battery.... My jeep won't start.

The dash has the sway bar light flashing. I go under to look at it and the electrical connector is loose.

I tighten it and magically the jeep starts and runs fine.

I can't believe that stupid connector can mess up the entire computer. Man i hate when things are overly computerized. Like my dishwasher which never works.

Anyways... im both happy but astounded. I hope that was the end of it.
BROWNING50CAL_M2 is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 10-05-2017, 06:10 AM
Gunnery Sergeant USMC (ret)
 
Uncle Sams Misguided Child's Avatar
 
Join Date: Dec 2010
Location: Tucson AZ
Age: 52
Posts: 21,952
Feedback: 8 reviews

That doesn't make sense. I know lots of people that don't even have the smart bar connection hooked up and their jeeps run fine.

Quote:
Originally Posted by lohchief View Post
If people don't take a stand now,you'll be bitches under their thumbs tomorrow.
Quote:
Originally Posted by StubEXrube View Post
I think too much of a pressure variant between Earth and outer-space... lack of oxygen... something like that.
Uncle Sams Misguided Child is offline  
post #5 of 12 Old 10-06-2017, 05:58 AM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews

Driving home from work this morning, got a U0001 code - high speed CAN communication BUS. The Jeep is driving perfectly fine though. Oh the suspense of what will happen next...
BROWNING50CAL_M2 is offline  
post #6 of 12 Old 10-06-2017, 06:01 AM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews

Quote:
Originally Posted by Uncle Sams Misguided Child View Post
That doesn't make sense. I know lots of people that don't even have the smart bar connection hooked up and their jeeps run fine.
I agree... it doesn't make sense bit I'm just telling what happened. I have a feeling this is gonna be a headache of a problem. Hopefully not.
BROWNING50CAL_M2 is offline  
post #7 of 12 Old 10-07-2017, 07:08 AM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews

So I filled the e disco with dielectric grease and zip tied the electrical connector shut. Now my sway bar light won't stop flashing. The fun continues..
BROWNING50CAL_M2 is offline  
post #8 of 12 Old 10-08-2017, 03:27 PM
Wheeler
 
uglysami's Avatar
 
Join Date: Dec 2012
Age: 34
Posts: 85
Feedback: 0 reviews

Quote:
Originally Posted by BROWNING50CAL_M2 View Post
So I filled the e disco with dielectric grease and zip tied the electrical connector shut. Now my sway bar light won't stop flashing. The fun continues..
In my experience working on several electrically controlled machines too much dielectric grease can cause more issues. Even in JLG and Genie trouble shooting it's the first step to clean out dielectric grease.
uglysami is offline  
post #9 of 12 Old 10-08-2017, 06:31 PM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews

Yeah i think you're right. I put too much in. I'll clean it out and see what happens.
BROWNING50CAL_M2 is offline  
post #10 of 12 Old 10-30-2017, 06:09 PM
Wheeler
 
Blakspire's Avatar
 
Join Date: Aug 2012
Posts: 50
Feedback: 0 reviews

Sorry I'm late to the party, but if this is a still an issue...

This was a recurring issue with me. Heres my thread on JKF. --->

https://www.jk-forum.com/forums/stoc...5/#post4198832

I ended up disconnecting and disabling the bar entirely. JKS Quicker discos FTW!!!

Side note, just disabling the bar will not stop the problem, as it drags the whole CAN down to ground.

EDIT:

You can use a procal to remove the Smart Bar function completely. Its ~1300 to buy a new smart bar. Buy discos.

Last edited by Blakspire; 10-30-2017 at 06:14 PM.
Blakspire is offline  
post #11 of 12 Old 11-13-2017, 05:11 PM Thread Starter
Wheeler
 
Join Date: Jul 2013
Location: Port Moody, B.C. Canada
Age: 39
Posts: 22
Feedback: 0 reviews

Yeah
I have cleaned put the electrical connector with contact cleaner and the light still flashes. Gotta figure out my next move.
BROWNING50CAL_M2 is offline  
post #12 of 12 Old 11-13-2017, 07:27 PM
Wheeler
 
Blakspire's Avatar
 
Join Date: Aug 2012
Posts: 50
Feedback: 0 reviews

The indicator will flash indicating there is a problem with the smart bar (the module may be damaged/full of water).

Leave the bar disconnected and see if the problem continues. That light will always flash as long as it doesn't detect the bar, or believes there is a problem with it.

If you have a superchips or procal, disable the bar, disconnect it, and drive around. See if your dash does the funky chicken anymore.
Blakspire is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome