Turn signals, horn, interior lights, rear wiper... DRIVING ME CRAZY! - JKowners.com : Jeep Wrangler JK Forum
 2Likes
  • 1 Post By RubiCajun
  • 1 Post By 0lllllll0 RPMEXTREME
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 09-20-2017, 05:44 PM Thread Starter
Newbie
 
Join Date: Sep 2017
Posts: 1
Feedback: 0 reviews
Exclamation Turn signals, horn, interior lights, rear wiper... DRIVING ME CRAZY!

2007 Rubicon, 2 door, auto. I've only owned it for a few months now but the electrical gremlins are in full force.


Preface: I have replaced all turn signal bulbs, side marker lights, and reverse lights with brand new standard incandescent bulbs for troubleshooting. I have replaced the turn signal stalk assembly with an OEM part. I have replaced one of the 15a turn signal fuses.

Where to start? The symptoms differ based on whether or not you have the running lights turned on.

Running lights OFF: the turn signals will work normally 90% of the time, but they will occasionally start to hyper flash. The front and rears both illuminate at this time, they just hyper flash. The only way to get them to stop hyper flashing is to shut the Jeep off and restart it. Hazard lights operate normally both before and after hyper flashing begins.

Running lights ON: the turn signals will blink 8 times and on the 9th time, it will start to hyper flash. The difference here is that the front turn signals won't illuminate at all (even as DRL) after one side starts to hyper flash. Rear turn signals illuminate even after the front signals stop, but they still hyper flash. Hazard lights will work normally until the hyper flashing begins, at which point the rears will blink at normal speed, but the fronts still won't illuminate. Again, the only way to return them to normal is cycle power via the key.



Other issues, not as pressing, but still annoying and possibly related:

The horn: it worked when I got the Jeep but mysteriously stopped working. I checked both fuses and they were okay. I have not checked the switch/contacts behind the airbag yet. The clockspring recall repair was performed by the dealer prior to my ownership.

Interior lights: the dome light occasionally will not shut off when all the doors are shut. The only way to get it to turn off is to turn the switch all the way back on the stalk. It's a 50/50 chance if it wants to turn off properly. The DOOR message does not display on the gauge cluster like it does when a door is not fully shut.

Rear wiper: the rear wiper will stop mid cycle and may or may not begin working after you turn the jeep off and restart it. This is on the other column stalk obviously, but since they are jumpered together I figured it would be worth mentioning, as they could be related.



I guess I'm hoping for something fairly simple. Maybe a common ground that has corroded, or a spot where the wires wear through and short out, like the XJ wires do where it passes from the door into the cabin. I'm fairly new to JK ownership so I'm not keen on the common issues. What I'm hoping it ISN'T is the damn TIPM. Any help would be greatly appreciated!

(Yes, this is cross-posted to JK-Forum for maximum exposure!)
Yodwinder is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-21-2017, 08:25 AM
Rock God
 
D94R's Avatar
 
Join Date: Jul 2012
Age: 34
Posts: 915
Feedback: 0 reviews

Quote:
Originally Posted by Yodwinder View Post
What I'm hoping it ISN'T is the damn TIPM. Any help would be greatly appreciated!
Well, you can hope in one hand and shit in the other.





For the symptoms to be reliably repeatable, all signs point to a TIPM man, sorry.

2007 JKU Sahara........................... 2015 JKU Sahara
5.3/6l80E......................................2.5" Rock Krawler Expedition Stage-1
Teraflex 44 front, Stock 44 rear........35's
Bastard lift
Totaled; being rebuilt
D94R is offline  
post #3 of 5 Old 09-21-2017, 11:21 AM
Comfortably Numb
 
RubiCajun's Avatar
 
Join Date: Dec 2008
Location: Louisiana
Posts: 12,289
Garage
Feedback: 1 reviews

Agree with D94 but before you do anything else try disconnecting both battery leads and touching them together. There may or may not be a small spark. Wait about 30 minutes and then reconnect the battery leads. Hope this helps.
JK in SC likes this.

08 Rubi Unlimited named Freebird

Quote:
Originally Posted by StubEXrube View Post
Cat killing would almost certainly decline if we were allowed to hunt liberals.
Asylum media group llc all rights reserved 2015
RubiCajun is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 09-29-2017, 12:16 PM
JKowners Vendor
 
0lllllll0 RPMEXTREME's Avatar
 
Join Date: Jan 2012
Location: Birmingham, Alabama
Age: 42
Posts: 682
Feedback: 2 reviews

I think the lights and horn share a ground near the LF headlight.

I remember someone else having issues after a light mod and it turned out he tied into the ground wire
JK in SC likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
your offroad connection to the best southern off road Jeep parts in Alabama
0lllllll0 RPMEXTREME is offline  
post #5 of 5 Old 11-21-2017, 06:51 PM
Newbie
 
Join Date: Sep 2015
Age: 42
Posts: 2
Feedback: 0 reviews

This is exactly what I am going through with turn sig and lights. What did you end up doing?
AngryJK5829 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome