P0340 Cam Sensor and Traction control Errors - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 05-10-2017, 05:18 PM Thread Starter
Wheeler
 
jchappies's Avatar
 
Join Date: Apr 2017
Location: San Diego Area
Age: 46
Posts: 83
Garage
Feedback: 0 reviews
P0340 Cam Sensor and Traction control Errors

I'm having an electrical gremlin maybe someone has had the same issue.
P0340 Cam position sensor and TC light come on at almost the exact same location everyday (after clearing codes)
I've changed the Cam sensor and re-installed the original cam sensor with same results
I've cleaned the plug with contact cleaner
Not sure what else to look for...any help?

11 JKUR Auto, RIPP SC, Body Armor bumper, Warn XD9000I winch, Synthetic line,XRC Rear Bumper W/carrier, OBA W/1Gal Tank, 10lb CO2, Metalcloak 3.5 springs, Synergy track bar,drag link flip-Tie Rod, control arms and Ball Joints, C-gusset and sleeved, RuffStuff Diff. covers, FOX W\res shocks, Barricade Flat Fenders, 37 12.50\17 BFG KO2, 5.38 Motive gears, Uniden 520xl CB, Yaesu FT7900, Teraflex Big Rotors, Diablo Intune, Dynomax RC exhaust Redneck Ram. W3JEP San Diego Jeep Club-Gulf War Vet. USAF
jchappies is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 05-10-2017, 07:10 PM
Rock God
 
tapcola's Avatar
 
Join Date: Jan 2013
Location: Las Vegas
Posts: 1,081
Feedback: 0 reviews

Quote:
Originally Posted by jchappies View Post
I'm having an electrical gremlin maybe someone has had the same issue.
P0340 Cam position sensor and TC light come on at almost the exact same location everyday (after clearing codes)
I've changed the Cam sensor and re-installed the original cam sensor with same results
I've cleaned the plug with contact cleaner
Not sure what else to look for...any help?
You know to leave that little red plastic peace on when you put it in right ? It sets the gap and just falls off when you start it up.

Sent from my SAMSUNG-SM-G891A using Tapatalk

SYNERGY, FOX,VKS,HUTCHINSON,
tapcola is offline  
post #3 of 8 Old 05-10-2017, 07:46 PM Thread Starter
Wheeler
 
jchappies's Avatar
 
Join Date: Apr 2017
Location: San Diego Area
Age: 46
Posts: 83
Garage
Feedback: 0 reviews

yes the small orange spacer was on it

11 JKUR Auto, RIPP SC, Body Armor bumper, Warn XD9000I winch, Synthetic line,XRC Rear Bumper W/carrier, OBA W/1Gal Tank, 10lb CO2, Metalcloak 3.5 springs, Synergy track bar,drag link flip-Tie Rod, control arms and Ball Joints, C-gusset and sleeved, RuffStuff Diff. covers, FOX W\res shocks, Barricade Flat Fenders, 37 12.50\17 BFG KO2, 5.38 Motive gears, Uniden 520xl CB, Yaesu FT7900, Teraflex Big Rotors, Diablo Intune, Dynomax RC exhaust Redneck Ram. W3JEP San Diego Jeep Club-Gulf War Vet. USAF
jchappies is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 05-10-2017, 07:51 PM Thread Starter
Wheeler
 
jchappies's Avatar
 
Join Date: Apr 2017
Location: San Diego Area
Age: 46
Posts: 83
Garage
Feedback: 0 reviews

It seems to happen around the 40 mile mark after reset
I can drive to work (30 miles) with no issues then about 10 miles into coming home it throws a code and goes into limp mode

11 JKUR Auto, RIPP SC, Body Armor bumper, Warn XD9000I winch, Synthetic line,XRC Rear Bumper W/carrier, OBA W/1Gal Tank, 10lb CO2, Metalcloak 3.5 springs, Synergy track bar,drag link flip-Tie Rod, control arms and Ball Joints, C-gusset and sleeved, RuffStuff Diff. covers, FOX W\res shocks, Barricade Flat Fenders, 37 12.50\17 BFG KO2, 5.38 Motive gears, Uniden 520xl CB, Yaesu FT7900, Teraflex Big Rotors, Diablo Intune, Dynomax RC exhaust Redneck Ram. W3JEP San Diego Jeep Club-Gulf War Vet. USAF
jchappies is offline  
post #5 of 8 Old 05-10-2017, 10:10 PM
Granite Guru
 
whiteyjfm's Avatar
 
Join Date: Sep 2011
Location: Califormia
Age: 48
Posts: 430
Feedback: 0 reviews

My friend has the same problem on his 2013 Rubicon. Dealer has replaced sensors and all sorts of things and it still happens. His Jeep is back at the dealer as we speak. He found a few cases that state that it is the wire harness that has a short on it. Some people got a new harness and that solve the problem for them. He was asking the dealer this time to change it. Time will tell id Chrysler will OK that repair this time.
whiteyjfm is offline  
post #6 of 8 Old 05-11-2017, 08:08 PM Thread Starter
Wheeler
 
jchappies's Avatar
 
Join Date: Apr 2017
Location: San Diego Area
Age: 46
Posts: 83
Garage
Feedback: 0 reviews

Day 1 without a code....
I took the sensor out and got another spacer but this time i hit the top of the sensor with a flathead screwdriver and a mallet to be sure it gets seated all the way down. I also bent the pins in the sensor just a bit for a tighter fit. I don't know what trick worked but first day without a code. Hopefully it fixed it...tired of the P0340 code and limp mode.

11 JKUR Auto, RIPP SC, Body Armor bumper, Warn XD9000I winch, Synthetic line,XRC Rear Bumper W/carrier, OBA W/1Gal Tank, 10lb CO2, Metalcloak 3.5 springs, Synergy track bar,drag link flip-Tie Rod, control arms and Ball Joints, C-gusset and sleeved, RuffStuff Diff. covers, FOX W\res shocks, Barricade Flat Fenders, 37 12.50\17 BFG KO2, 5.38 Motive gears, Uniden 520xl CB, Yaesu FT7900, Teraflex Big Rotors, Diablo Intune, Dynomax RC exhaust Redneck Ram. W3JEP San Diego Jeep Club-Gulf War Vet. USAF
jchappies is offline  
post #7 of 8 Old 05-27-2017, 05:28 PM
Newbie
 
Join Date: May 2017
Posts: 1
Feedback: 0 reviews

Same issue ,engine light trac control 40 ile mark. Have you had anymore issues since last fix?
Tex45acp is offline  
post #8 of 8 Old 05-27-2017, 07:42 PM Thread Starter
Wheeler
 
jchappies's Avatar
 
Join Date: Apr 2017
Location: San Diego Area
Age: 46
Posts: 83
Garage
Feedback: 0 reviews

No more issues. Probably 1K miles since i fixed this.
Got the sensor down in the hole as far as i could.

11 JKUR Auto, RIPP SC, Body Armor bumper, Warn XD9000I winch, Synthetic line,XRC Rear Bumper W/carrier, OBA W/1Gal Tank, 10lb CO2, Metalcloak 3.5 springs, Synergy track bar,drag link flip-Tie Rod, control arms and Ball Joints, C-gusset and sleeved, RuffStuff Diff. covers, FOX W\res shocks, Barricade Flat Fenders, 37 12.50\17 BFG KO2, 5.38 Motive gears, Uniden 520xl CB, Yaesu FT7900, Teraflex Big Rotors, Diablo Intune, Dynomax RC exhaust Redneck Ram. W3JEP San Diego Jeep Club-Gulf War Vet. USAF
jchappies is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome